This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 3 voices.

Last updated by emrahO-2 5 months, 1 week ago.

Assigned support staff: Bruno.

Author Posts
April 24, 2019 at 12:52 pm #3673041

oguzhanA

Hello,

The google maps in the fusion builder (Avada Theme) doesn't work in the translated page. You can see in the screenshot what I see. It works perfectly fine in the original language. We're not using WPML translation editor. I also tried to add just the shortcode, it still doesn't work. Could you help?

I am trying to: Use google maps from fusion builder

Link to a page where the issue can be seen: hidden link (the map you see there is embedded code from google maps, not the avada shortcode)

I expected to see: hidden link

Thank you,

April 24, 2019 at 8:53 pm #3676831

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us. What steps should I take to replicate the problem? How are these maps being added? Can you please elaborate a little more so I can better understand?

Also, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

April 25, 2019 at 9:52 pm #3686053

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I've seen the problem you're reporting, but I'm not sure if this is a WPML-related issue.

At the time, I tested this on a new installation and it worked correctly. You can see in this link: hidden link

In the link above, can you test and verify that you can replicate the problem?

As this module is being "disabled" but is being loaded, this seems to be done with some purpose. Maybe you should contact the author of your theme as well to know why the module is being disabled.

Thank you.

April 26, 2019 at 9:46 am #3689321

oguzhanA

Hi,
I wrote to you because it's not "disabled" in the english original version, it only becomes "disabled" in the translated page.

I could not replicate the problem in the test site because we get a different error there: hidden link

April 26, 2019 at 2:48 pm #3691687

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

About our testing environment, the problem that was happening on the page was simply because I had not added the API in the backend - since the problem is in the backend I did not look at the front end. By adding this API the map was displayed correctly on the front end.

About the overlay that is happening on your site, I asked you to contact the author of your theme because that might be some option that I do not know. There seems to be no script problem. This seems to happen intentionally, I'm just not sure why.

By contacting the author of your theme, you can know when this happens and then we can find out if it is a compatibility issue, bug or even some configuration.

Thank you.

May 3, 2019 at 3:31 pm #3736095

oguzhanA

OK, I sent a support request to Avada, let's see what they say.

May 7, 2019 at 6:05 pm #3761073

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sure. Thank you. Please let me know what they think about it.

Thank you.

May 7, 2019 at 9:37 pm #3762247

oguzhanA

Seems like the API credentials was supposed to be entered in both languages in Avada options. My issue is resolved now. Thank you!

May 22, 2019 at 3:11 am #3860327

emrahO-2

Thank you very much Oğuzhan, it solved my problem. It was looking like dead end 🙂