This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to translate a page from English to Chinese. I expected to see the gallery exactly same both on English & Chinese. Solution: You need to set the Masonry setting on each image for Chinese version again according to Avada support response.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by patt-2 3 months ago.

Assigned support staff: Radu.

Author Posts
July 17, 2019 at 8:01 am

patt-2

I am trying to: Duplicated & translated a page from English to Chinese

Link to a page where the issue can be seen: hidden link

I expected to see: Gallery should be exactly same both on English & Chinese

Instead, I got: Gallery can't display "masonry" setting

July 17, 2019 at 9:39 am #4228295

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Patt,

Thank you for reaching out the WPML support!

I just checked the masonry option of the gallery and it seems that the value for it is copied to the translation too. You can see it as the last field when you edit the translation. I'm not familiar with this gallery element so can you tell me if there's any option of the gallery that needs to be set in order to have the first image bigger, please? This way I'll be able to check it too and see if it's copied well to the translation.

Thanks,
Radu

July 17, 2019 at 10:21 am #4228593

patt-2

Hi Radu,

I think "masonry" is corrected, but it seems can't display as masonry.
Gallery element options of English & Chinese are same.

When I used String translation the check, I find that the page hidden link
have strings translation for gallery shortcode, as attached image.
hidden link
don't have such kind strings.

July 18, 2019 at 8:40 am #4236035

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Patt,

Good find about the shortcode not being registered in String translation!
In this case, can you delete the translation of the Job References page (from here hidden link - don't forget to delete it permanently), create again the translation, and see if the shortcode for this page appears in String translation? Please let me know how it goes.

Thanks,
Radu

July 19, 2019 at 10:33 am #4245783

patt-2

Hi Radu,

Thank you for your reply.
I also asked the same question to Avada, they just replied as I added translations for media library that it should have same setting for each image. That means I need to set the Masonry setting on each image for Chinese version again.

Now the problem is solved.
Thank you for your help.

July 19, 2019 at 10:33 am #4245785

patt-2

My issue is resolved now. Thank you!