Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:

When the Portfolio slug is translated, links to a portfolio posts go to the default post

Solution:

The problem happens when translating the pages that include the portfolio links with WPML's Classic Translation Editor. Please use WPML's Advanced Translation Editor to translate pages with the portfolio links. Then the links on the translated pages will point to the translated portfolio items.

Relevant Documentation:

https://wpml.org/documentation/theme-compatibility/using-wpml-with-the-avada-theme/

https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 2 voices.

Last updated by dosvisual.com 1 month, 1 week ago.

Assigned support staff: Itamar.

Author Posts
May 2, 2021 at 11:40 am #8670539

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi,

I'm sorry for not being clear enough about the workaround. I'll explain myself better now. But before I proceed with my explanation, I want to inform you that I'm in contact with Drazen, my colleague, about your other ticket and issues here.

https://wpml.org/forums/topic/global-element-not-showing-translated/

As for the workaround I provided in this ticket. The workaround does not include the translation of the Portfolio slug. What the workaround enables is to have the links on translated pages point to the translated Portfolio posts. And to achieve this, the Portfolio slug needs to be untranslated. Another workaround would be to manually translate the links to the translated Portfolio posts while translating the page. I understand that none of the above workarounds is desired by you, but unfortunately, this is what I can currently suggest. I'm sorry for the inconvenience that this issue is causing you.

I escalated this issue to our compatibility team, and when I have news regarding this issue, I'll update you here.

Thank you for your patience.
Itamar.

May 3, 2021 at 9:43 am #8674319

dosvisual.com

Hello Itamar
Thank you.
I´ve just done some tests and found out where the bug could be happening.

The portfolio slugs have many places where to be translated:
1) Avada options> portfolio> general portfolio> portfolio slug
2) Wpml >Post Types Translation> post types translation
3) WPML > string translation

I´ve checked that>
1) CAT was "pellicules" / ESP also "pellicules" / ENG "film" ---> they should be the 3 equals, or the 3 different...

So I reset all the slug translations, on 1), 2) and 3).
Saved the permalinks.
Then started translating from scratch, 1), 2) and 3).
Saved the permalinks.

RESULT> 1) CAT was "pellicules" / ESP also "pellicules" / ENG "film"

Then I manually changed the ESP slug on 1).
Then made some changes on 1) in ENG (header content, TEL number). It is not being saved. (This is on the other ticket, which no one has replied to yet and I think it is all related).

Now checking 1), 2) and 3), all the slugs are correct (so far).

The links keep on being translated super randomly on the same page and type of format (inside text blocks) on ESP/ENG> hidden link.
For e.g>
---> hidden link (this should be pointing at hidden link)
----> hidden link (this should be pointing at hidden link )
----> (This is the craziest): hidden link (this should be pointing at hidden link)

So, I suggest the problem could be an incompatibility between Avada and the slug translation ...

Hope you can find the solution soon!
Thanks

avada-header-eng-not-updating-FRONTEND.png
avada-global-ENG-header-content-not-saving.png
slugs-WPML-post-types-translation.png
slugs-string-transation.png
slugs-avada-global-options-ESP.png
slugs-avada-global-options-ENG.png
slugs-avada-global-options-CAT.png
May 3, 2021 at 11:59 am #8675831

dosvisual.com

A bit more of info:

I´ve updated a page> hidden link with a text block and a link to a portfolio> hidden link

The translation in ESP points to> hidden link

landing-portfolio-link-ESP-wrong.png
May 3, 2021 at 12:26 pm #8676189

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, and thanks for updating me on your findings.

As I mentioned, this issue is already escalated to our compatibility team, and they will debug this issue. If our compatibility team would find a workaround for this issue, I'll share it with you as soon as possible. But it is also important for me to mention that the solution for this issue may require the cooperation of the Avada developers. In that case, since the cooperation of two parties is needed, the permanent fix might take time to roll out. In the meantime, as I suggested, please do not translate the portfolio slug, 'pellicula'. Leave it untranslated. Or manually fix each link in WPML's Translation Editor when you translate the pages. I understand that it is a lot of work, but I'm sorry, which I can suggest at the current time.

As for the other new ticket that you are still waiting for a first reply, I'm sorry that it takes time. Our support forum is a little bit loaded in the last few days. You should get the first reply from one of my colleagues soon.

Best Regards,
Itamar.

May 3, 2021 at 12:34 pm #8676345

dosvisual.com

Hello Itamar
Thanks for your reply.
Our launch is on the 10th of May and this should be solved in a couple of days maximum, inorder to have time to load the 50 new portfolios...

Now you said it could take a long time, I will have to change my whole url structure and move on to posts or pages instead of portfolios. That´s really bad news 🙁

Hope you can fix this and the other bugs soon.
Thank you very much.

May 3, 2021 at 10:23 pm #8679135

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi,

I understand your feelings and know how a website launch deadline can be stressful.

You wrote: "Now you said it could take a long time, I will have to change my whole URL structure and move on to posts or pages instead of portfolios."

I do not think that you should go through all this work. There is a shorter way that you can take to achieve this. Let me, please remind you that the problem is only with the links to the translated portfolio posts and not with the translated portfolio post if you view them directly. Therefore here is my suggestion.

1. Go to WPML -> Settings -> Post Type Translation, and insert the translations you want to have for the Portfolio slug. Please see the attached screenshot steps-1-2.jpg.

2. View the translated portfolio post on the frontend and copy its URL. Please see the attached screenshot step3.jpg.

3. Edit the page with the portfolio links and press the pencil icon to edit the translation. Please see the attached screenshot step4.jpg.

4. While editing the translation of the page with WPML's Translation Editor, look for the fields that contain the links to the portfolio posts, and edit the links on the translation side. Please see the attached screenshot step5.jpg.

5. Paste the URL of the translated portfolio post, Enter button. Repeat this for all the other links on this page and press the Save and Close button. Please see the attached screenshot steps-678.jpg.

Repeat this on all the pages with links. Now the link will work as you expect them to work on the translated pages.

For the time being, this is the best suggestion I can offer to you. I hope that you'll find it helpful in the current situation. Other than this, there is not much I can do until I have a response and hopefully a fix from our compatibility team. At this point, I would also like to refer you to our support policy here.

https://wpml.org/purchase/support-policy/

Especially please read this section.

Fix Bugs in WPML

This one may sound strange, but it’s true. If you find a bug in WPML, we take it very seriously. We’ll add it to the bug-fix queue and work on it. However, we can’t fix everything right that minute. So, if you hit a bug that’s keeping you from doing something, we can’t promise that we’ll fix it right away.

We’ll work with you to find a sensible temporary solution and let you know as soon as it’s fixed, but we can’t guarantee any schedule.

When I have an update from our compatibility team regarding this issue, I'll update you here.

Best Regards,
Itamar.

steps-1-2.jpg
step3.jpg
step4.jpg
step5.jpg
steps-678.jpg
May 4, 2021 at 8:50 am #8681971

dosvisual.com

Hello Itamar
Thank you for your reply.

I will follow your suggestion!
Thanks for the dedication and I know the wpml team is really good.
Only this time, I had the bad luck of experimenting too many bugs at the same time.

I wish you luck to find a solution soon.
Thanks again.

May 6, 2021 at 10:13 am #8702923

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi,

Our compatibility team check this issue and found out that when using WPML's Advanced Translation Editor, the links to the translated portfolio posts work correctly. I check it on my test site and confirm that it is so. Please see the test page I created here.
hidden link

This issue will be fixed in future versions of WPML. In the meantime, please use the workaround and translate the pages with the Advanced Translation Editor.

I'll update you here when a version with the fix is released.

Regards,
Itamar.

May 6, 2021 at 1:29 pm #8705181

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi again.

Our compatibility developer explained that since things work with WPML's Advanced Translation Editor, it is not a bag that needs to be fixed. He added that in upcoming versions of WPML, we would recommend using only the Advanced Translation Editor. And further, in the future, it will be the only Translation Editor available with WPML. So please continue to work and translate the pages with the portfolio links with the Advanced Translation Editor. And as a general recommendation, use it for all translations on your site. You can read about the Advance Translation Editor at the following link.

https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

Please let me know if you have further questions regarding this issue.

Best Regards,
Itamar.

May 6, 2021 at 6:42 pm #8708289

dosvisual.com

Hello Itamar
Thanks for your replies.
I think that while there are WPml users using the classic editor, it´s a bug that needs to be fixed...

Regarding the Advanced editor, wow.. I understand it´s going to be THE way, but that transition needs to be informed to the customers so that we can all reorganize the multiple websites that use the classic editor. I understand that the Advanced editor recognizes the classic´s editor translations except for the body... so that transition could be problematic for large content websites..

My deadline for this website is the 10th of may and I´m super delayed for all the bugs I ran into with wpml and avada. Do you think that switching to the advanced editor now would be without problems nor new bugs popping up?

Thanks

May 9, 2021 at 12:09 pm #8723127

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi,

I can not guaranty that there will be no other issue when you switch to the Advanced Translation Editor. I recommend that you will first test it with one page. Here is the process I recommend to test.

1. Make sure that the translation of the page is complete.

2. Go to WPML -> Translation Management and through there send this page to the Translation Basket. And from the Translation Basket to the Translation Jobs.

3. Assign this job to a local translator. Please do this process from steps 2-3, even if you are the WordPress user who will translate this job.

4. In WPML -> Translations, take this job and translate it with the Advanced Translation Editor.

If it looks like the old translations from the Classic Translation Editor are not showing on the Advanced Translation Editor, please follow the explanations on this guide.

https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/using-translations-from-other-sources-in-the-advanced-translation-editor/

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Regards,
Itamar.

May 10, 2021 at 4:16 pm #8731931

dosvisual.com

Hello Itamar

Thank you for the steps. I tried with one page, but me and my collaborators (also my customer), we are all used to the classic editor and we have no time to implement a new way of translation with such short notice.

I´m sure the team is working to make WPML better for evryone! But the transition to the Advanced editor is something serious and I suggest you inform your customers properly and offer a viable solution to "migrate" the contents translated with the classic editor so that we do not have to retranslate (and re teach how to) everything that has been created through the years!

Thank you in advance!

May 11, 2021 at 8:16 am #8735975

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, and thank you for this feedback.

For your information, the Advanced Translation Editor is officially included in WPML since version 4.0 almost three years now.

https://wpml.org/changelog/2018/06/wpml-4-0-released/

Our developers are constantly working on improving it and the smooth transition between the different translation methods. We have extensive documentation and guides on our site that, when necessary, include videos. Here are some (not all) helpful links to guides about using the Advanced Translation Editor.

https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

https://wpml.org/announcements/2018/06/machine-translation-available-in-wpmls-advanced-translation-editor/

https://wpml.org/documentation/automatic-translation/

https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/using-translations-from-other-sources-in-the-advanced-translation-editor/

And we are always here to help with any WPML issue or question 🙂

Also, please know that you can submit a feature request that goes directly to our developers at the following link.

https://wpml.org/suggest-a-new-feature-for-wpml/

They will consider whether it is possible or needed to add this feature.

And at the following link, you can contact our office with any none technical issues or requests.

https://wpml.org/home/contact-us/contact-form/

As I can see so far, we discussed all the aspects of this issue in this ticket, and I would like to close it. Please let me know if you have another specific question regarding this issue.

For any new questions or issues please open a new ticket in our support forum.

Best Regards,
Itamar.

May 12, 2021 at 5:17 pm #8751209

dosvisual.com

Helo Itamar

Thanks for the information.
I know the Advanced editor has been out for a long time, but it was never mentioned it would end up being the ONLY editor. That is what I´m referring to.

I chose the classic editor from the begining because I found it easier to use. It´s going to be massive work to transition to the advanced one.

I will try to make the official suggestion I mentioned before, as soon as I have some free time (I still need to open more tickets for more bugs keep showing up on the same website).

You can close the ticket.
Thank you!

May 12, 2021 at 5:23 pm #8751219

dosvisual.com

The bug has not been solved, hope it does sooner than later.