This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by Andrés 1 year ago.

Assigned support staff: Andrés.

Author Posts
October 11, 2018 at 8:54 am #2807231

erminiaf-2

Tell us what you are trying to do? I am trying to: switch language inside a portfolio post

Link to a page where the issue can be seen: hidden link

Guide: https://wpml.org/forums/topic/avada-theme-portfolio-slug-only-working-in-one-language-at-a-time/

I expected to see: post in english

Instead, I got: error 404

October 11, 2018 at 4:38 pm #2809141

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @erminiaf-2, welcome to the WPML support Forum!

Have you translated the portfolio slug? If so, how was it done?

Please go to Settings > Permalinks, set it as "simple" and save. After that, switch back to the previous structure and save again.

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.
NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

Please let me know if it worked for you.

All the best,
Diego

October 12, 2018 at 7:58 am #2811042

erminiaf-2

Hi Diego,
I translated the slug into Avada's options, but I was always a 404.
Do I have to translate it into the WPML settings?? (see image).

In the reply there is no field to insert the debugging text....

October 12, 2018 at 10:26 am #2811584

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

As Diego is not available I would like to take care of your case.

Yes, you need to translate your portfolio slug from that section on your WPML settings. After that, don't hesitate to resave your permalinks.

Does it help?

Regards,
Andrés

October 12, 2018 at 1:06 pm #2812077

erminiaf-2

Dear Andrés,
I translated the slug and saved the permalinks, but neither Italian nor English worked.
To reset everything, I set the slug of the first language from the Avada options.

October 12, 2018 at 2:24 pm #2812312

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

In that case, let's check that everything is working as expected:

1. Could you please upgrade all your WPML package?

2. Could you please check that your Avada theme is up to date 5.7:
hidden link

3. If you disable Redirection plugin, the issue is still present?

Regards

October 12, 2018 at 2:38 pm #2812343

erminiaf-2

1./2. I can't do this because I can't upgrade Avada Theme (who built this site didn't create a child theme...)
3. If I disable Redirection plugin, the issue is the same.

Should I redo the website from scratch ?! the situation is embarrassing ...

October 12, 2018 at 2:46 pm #2812355

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

If the problem comes from your Avada theme, there is nothing I can do as we need to work with the latest version of themes and plugins.

However, why is not possible to upgrade your WPML package?

October 12, 2018 at 2:51 pm #2812357

erminiaf-2

I contacted the Avada' support and told me that depends on the WPML plugin. The current version of the theme does not support the new version of WPML.
As I see in the forum, this problem is not just mine ...

October 12, 2018 at 3:22 pm #2812408

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thanks for the new info. But could you please upgrade your WPML package?
Otherwise we can't continue.