Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by hollyJ 1 month, 1 week ago.

Assigned support staff: Alejandro.

Author Posts
October 14, 2021 at 2:15 pm #9791013

hollyJ

One of the Avada slides in the home page translation has not translated (it also appears twice on the french side). I have tried to go in and edit one and now it is stuck on 'being translated'. How can I resolve this? see 'stuck-in-processing.png'. When open this for translation is where I am seeing 2 things:

a) the content is not translated in the title or button although it seems to say it is when using the automatic translation.
b) there are no credits - which I presume means the staging site is not attached to my account?

October 14, 2021 at 2:28 pm #9791135

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

We're only going to work on the avada slides here.

If you had translated the page already, please wait a bit. if by now the page is still with the same status, please go to WPML > Translation Management > Translation jobs, find "home2" and press the red X (cancel job).

However, i'm not sure what to tell you with the avada slide other than to check this guide on how to translate Slides from avada:

https://wpml.org/documentation/theme-compatibility/using-wpml-with-the-avada-theme/#translating-avada-sliders

As you can see on the images from our guide, you can check the slides directly by changing the language of the language switcher found on the WordPress topbar, so you can change the language switcher to french and delete the duplicated slide, then translate it to the missing language.

October 14, 2021 at 2:31 pm #9791155

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

About the credits, instead, you can check if you have credits available or not only if you have an active membership for the automatic translations.

you can check if you have an active membership by going to WPML > Translation management > Translation tools and from over there you can see a set of options if the membership is active, or you can see a call to action inviting you to sing up if you don't.

then, you can check in the payments tab, if you have credits available or not.

October 19, 2021 at 10:06 am #9816761

hollyJ

Hi Alejandro,

Using the staging site again (with the same credentials for access as my other support requests) and the knowledgebase link you gave me for Avada sliders:

I have the Avada slides set up for the french side of the translation, but when I look at the french version it does not show the top slider. How do I select it? I have tried going to the bottom of the page on the french side (where one selects a slider) & the 'home' slider is not available to select.

I have also tried to go to the avada sliders and see about translating them, but again I am not sure if I should do this anyway, and if so, how I would do it?

Many thanks
Holly

Screenshot 2021-10-19 at 10.59.43.png
Screenshot 2021-10-19 at 10.58.20.png
Screenshot 2021-10-19 at 10.57.16.png
October 19, 2021 at 3:16 pm #9819915

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

The answer seems to be in one of your screenshots, which i highlighted on the attachment below. The actual slider is not translated so it won't appear in french because it doesn't exist (that's why it can't be selected).

Try to access the slider "home" and translate it as you would with any other page. then check if the slider is available now.

Let me know how it goes.

home slider avada.jpg
October 20, 2021 at 4:07 am #9823073

hollyJ

Hi Alejandro,
There doesn't seem to be any way to add translation to the slider. When I access it there is no facitility to 'translate it'. I do notice towards the bottom of the slider a box as per the attached screengrab. Should I be doing something with this?

Many thanks
Holly

Screenshot 2021-10-20 at 05.04.00.png
October 20, 2021 at 9:25 am #9824687

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Can you please go to WPML > Settings > Post type translation > Find "sliders" and set them to translate because i suspect they are set as not translatable.

Here's the guide on what you should expect, see and how you should translate the sliders: https://wpml.org/documentation/theme-compatibility/using-wpml-with-the-avada-theme/#translating-avada-sliders

October 24, 2021 at 1:59 pm #9851545

hollyJ

I did reply to this before, but it seems to not have gone through.
I think The sliders are set to translate. I do wonder if they should be set to the second option, ie fallback?

Do I need to create a separate slider for the french slides? If so how is this done and the french slides allocated to it.

October 25, 2021 at 6:47 am #9853779

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

There are 2 "translatable" options, one is the "fallback" method and the other one will only show the sliders in the front-end when they have been translated.

All the steps to translate the sliders are found in the link i have posted a few time through this ticket: https://wpml.org/documentation/theme-compatibility/using-wpml-with-the-avada-theme/#translating-avada-sliders , and yes, you need to translate the slider AND the slides into french, using the process described on the above mentioned link , otherwise you won't see it correctly in the french page.

You'll find step by step instructions on what to do and how to translate them. please follow it and if you get stuck on one of the steps, let me know which one so i can try to guide you.

Regards.

October 25, 2021 at 8:07 am #9854353

hollyJ

Hi Alejandro,
In the knowledgebase it makes no mention of translating the slider, only the slides, or how to attach the slider to the french version. Here is what I have done:

Using the page hidden link
- I have translated the 3 sliders on this page
- I then translated the page

The above was done as per the guidance from your knowledgebase and in that order.

When I go to look at the french side of the page hidden link there is no slider. If I scroll to the bottom of the page on the french side and try to attach the slider 'holiday offers' it is not available.

So what do I do next?

There is no facility to translate the sliders - or have I still got a setting wrong.

I previously tried a workaround on the home page - by creating a new slider from scratch on the french side and calling it home-french, and then by going to each of the translated slides on that page and attaching them to the french slider. Then going back to the french side of the page and attaching the new french slider.

Furthermore, when one goes to the sliders page although it indicates the number of sliders in english/french/languages (currently there is one showing in french which was the one I created from scratch = 'home-french') when one clicks on french, it doesn't show just the one slider it shows them all. I can scroll through to find the one I created manually, but I think this is a bug, or I am doing something wrong in the creation of sliders.

I have left the Holiday offers page without a newly created slider so you can perhaps take a look and give me correct guidance to get the translated slides to show on the french page.

October 25, 2021 at 8:42 am #9854863

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

May i have access to your site (using the related fields that will be enabled in your next reply) and the following:

- The name of the slider
- one slide belonging to the slider
- The page where the slider is going to be added

This will help me test a few things on your site and give you more detailed instructions on what to do next.

October 26, 2021 at 8:28 am #9862599

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Please check this video: hidden link

I can see that you actually had 1 slider translated already but you also had 1 issue which was fixed by following this procedure:

Go to WPML -> Support -> Troubleshooting
Press the following buttons:
• "Clear the cache in WPML"
• "Remove ghost entries from the translation tables"
• "Fix element_type collation"
• "Set language information"
• "Fix post type assignment for translations"

Afterwards i translated the slider (edit the slider and go to the bottom of the page, then click "add" under "translations", that's how you translate a slider).

Now all you need to do is modify the slide that was created in the past, maybe change a text, save it and update the translation of the slide and that should be it.

October 26, 2021 at 1:12 pm #9864791

hollyJ

Thanks Alejandro,
At last the Avada Slider issue is sorted. It must be said that the knowledgebase really does lack this part of the process with Avada Sliders - It would be great for them to update it. Meanwhile thank you again for your great help. It is much appreciated.
Kind regards
Holly