This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When I click at the edit link, i get a blank page

Solution: Please increase the PHP memory limit to 256mb. https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

This topic contains 3 replies, has 2 voices.

Last updated by Diego Pereira 11 months, 2 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
October 24, 2018 at 3:09 pm

bermetK

This is my first time using wpml plugin and I have problem with translation page. I have followed all automatic instructions and installed the wpml plugins. Currently, when i try to edit the page in original language it is blank.

i have tried to follow your instructions here https://wpml.org/errata/fusion-builder-avada-theme-translation-editor-is-blank-when-updating-the-translation-of-a-global-element/

but when i click edit link, i get blank page and i can not apply your instruction "In the language meta box, click the pen icon to update the translation" Maybe i have different bug which is not related to fusion builder.

My current problem i cant edit or translate pages since the pages are shown blank when i click "edit"

Could you please help me to resolve this problem.

Here are
[content removed]

October 25, 2018 at 7:04 pm #2850904

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @bermetk, welcome to the WPML support Forum!

The errata seems related to global elements. Are you trying to translate a global element or a page?

Could you please send us some screenshots of the original page + the black edit screen?

I also checked the settings of your server through debug log and saw that some items need attention:

PHP version
Upgrade the PHP to version 7 or higher. This is a practice recommended by the WordPress.org website: https://wordpress.org/about/requirements/

Increase WP memory
Please increase the PHP memory limit to 256mb. Currently this memory is set to 40mb.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

All the best,
Diego

October 30, 2018 at 1:27 pm #2861950
bermetK

Hello i have solved the issue with blank pages. You were right about php version and wordpress wp memory. When I increased my template back to normal.

But now I have another issue with translation of the pages. When I click the + icon the page translation opens (pic 2) and I complete all the translation and save it. After I back to the page editor and error appears on the right of the page which is shown on pic 3

Also the page is shown as not translated when i click the language flag on the top bar as it is shown at the pic 4

Why do i have this error and what i am not doing right. Also I want you to take into your consideration that this is my first time using wpml.

New threads created by Diego Pereira and linked to this one are listed below:

https://wpml.org/forums/topic/split-avada-theme-blank-page-error/

October 30, 2018 at 6:30 pm #2863309

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

As the previous issue has already been resolved, I will open a new ticket for this new one.

I will reply in the new ticket.

Regards,
Diego