Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: A translated page has a differnt layout

Solution: The Avada theme uses separate options per language. To solve this go to the Theme Options, select All languages from the top bar and Save the settings. This will set the same theme options for all languages.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.24 hours from now. Thank you for your understanding.

This topic contains 5 replies, has 2 voices.

Last updated by robertE-6 2 years, 8 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 25, 2019 at 10:28 am #3681097

robertE-6

I am trying to: Publish Portuguese translation - it works but reformats the page layout

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link and hidden link (which are both working fine)

Instead, I got: hidden link with the navigation pushed to the top and nowhere to configure to the correct layout. plus it's pulling in the Avada logo and not the SupportAbility logo. This is only just happened after I did the Portuguese and Turkish translation.

translation.jpg
April 25, 2019 at 1:33 pm #3682777

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our forum,

Seems like the layout is not properly copied to the translation, Please share temporary access to your site. I will check this in detail. I have enabled the private fields for you to securely share the details.

Kind regards
Raja

April 26, 2019 at 7:24 am #3688367

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I can check the issue. it's more likely that Advance editor did not copy Avada layout. Please clarify are you using the Advanced editor only for Portuguese translation?

Since you have already translated the page please switch to WPML classic editor from WPML > Settings > How to translate posts and pages. Update the original page (English) and the Portuguese translation. Check if the issue still persists.

Let me know the results.

Kind regards
Raja

April 26, 2019 at 3:28 pm #3692021

robertE-6

I did the Portuguese translation after the Turkish one using the Advanced editor. The Turkish language works the other one doesn't. I followed your instructions above but I am not quite sure about what you mean by 'Update the original page (English) and the Portuguese translation.' So I assumed you meant go into the page and click save. Anyway this did nothing and I am still with the incorrect Avada template on the Portuguese translation. I decided it might be better for me to update the Avada theme to the latest version (5.9) but sadly it has not resolved the issue. Please help.

April 29, 2019 at 6:16 am #3700181

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I checked your issue further. It seems like you have set a different layout style in Avada theme option for Portugues language which is why you are seeing a different layout for the Portuguese alone.

The Avada theme uses separate options per language. To solve this go to the Theme Options, select All languages from the top bar and Save the settings. This will set the same theme options for all languages.

As a precautionary measure, backup your site before proceeding with the above steps.

Kind regards
Raja

Screenshot 2019-04-29 at 11.45.25 AM.png
April 30, 2019 at 12:03 pm #3710813

robertE-6

My issue is resolved now. Thank you!