This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This topic contains 7 replies, has 2 voices.

Last updated by Andreas W. 1 day, 14 hours ago.

Assigned support staff: Andreas W..

Author Posts
March 25, 2020 at 7:16 pm #5763753

jose-luisC

With the latest WPML updates, the Awesome Weather Widget plugin stopped translating correctly. As you can see when switching the language in hidden link.

Thank you and kind regards,

José Luís Costa

March 26, 2020 at 12:44 am #5764877

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

How was the Widget placed into the site? If you are using a Widget that was placed inside of the theme options please read this:

http://wpml.org/2011/03/howto-display-different-widgets-per-language/

In this case you translate at WPML -> String Translation -> Text Domain: Widgets or you might try using one Widget for each language and adjust the widget language options accordingly.

If you used a shortcode to display the Widget please update the original page, like making a samll text edit, for example with a "blank" spacebar, then save the original page and translate it again.

Now, is the shortcode showing up inside of the WPML Translation Editor?

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

March 26, 2020 at 7:25 pm #5773341

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

You disabled our plugin Translation Management. May I ask why it is disabled and if it would be possible to activate it again?

I will then try to apply a custom XML confirm in order to make the widget translatable. Further, I would suggest translating the content with one of our WPML Translation Editors.

More information here:
https://wpml.org/documentation/translating-your-contents/translation-editor-options/

Kind regards
Andreas

March 26, 2020 at 7:30 pm #5773355

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Additional to my last message:

I enabled WPML -> Languages -> Language filtering for AJAX operations -> Store a language cookie to support language filtering for AJAX.

The issue was solved but appeared again. Please clear the cache and try running the site in minimal setup:

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know about the results. In case the debug-log is very long please add it to a web tool like pastebin.com and send me the link.

Kind regards
Andreas

March 26, 2020 at 8:44 pm #5773695

jose-luisC

Hi,

Thank you. The problem is WP Rocket.

March 26, 2020 at 9:27 pm #5773993

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

WP Rocket should be compatible with WPML.

https://wpml.org/announcements/2017/08/build-fast-multilingual-sites-using-wpml-and-wp-rocket/

Was the issue solved after deleting the Cache?

Kind regards
Andreas

March 26, 2020 at 10:21 pm #5774091

jose-luisC

Hi,

If wp rocket is inactive the translation of awesome weather plugin works.

March 26, 2020 at 11:24 pm #5774305

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I cleared the cache in WP Rocket and the issue was gone.

Those issues can only be solved after clearing the WP Rocket cache from time to time. You find this option in the top admin bar inside the WP Rocket Options.

Kind regards
Andreas