If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
January 17, 2019 at 2:04 pm

tomaszA-3

After the new wordpress (5.0) I have a major problems with page load time in the backend. I did all of the suggestion I found on your forum to optimize the speed of the website. I even moved my website to new - clean server. It helped a little but I am still waiting 30s-1m for any module in back-end to load.

Link to a page where the issue can be seen: hidden link

January 17, 2019 at 5:09 pm #3103144

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I visited the backend of the site and it seems to be working correctly. Could you provide the steps to reproduce the issue?

Kind regards,
Carlos

February 11, 2019 at 3:35 pm #3183852

tomaszA-3

It is anywhere I click in the backend. I just clicked "Plugins" and waited 12s to be in it. Before the translations to 4 languages the page run very fast. And I am able to understand that frontend is slower now after the translations but why the backend is - make no sense.

February 11, 2019 at 5:19 pm #3184638

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

This time I was able to reproduce the performance issue in the backend of the site.

In this case I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

February 25, 2019 at 6:42 am #3238087

tomaszA-3

Hi Carlos, yes I did all of suggested steps plus many other that I found on WPML forum. The problem is with WPML for sure and I know this because I have 3 other clients (greenlogic.pl, controlling-systems.pl, aspa.pl) with you plugin and all of them are very slow right now. Beside we also checked database queries. Please try to fix the problem on minipizza.pl and let me know where was the problem so that I could implement the solution to my other projects.

February 26, 2019 at 11:50 am #3244586

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Carlos is having vacations and I am going to handle this ticket further. WPML String translation does take a bit load on the server due to the features and functions it handles, most of the time it depends on how many content, plugins, strings are available in your site. We do have a few things we can try to improve things to some extent where possible. Can you please confirm that you have taken full site backup before I debug this further?

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

And we have released updated WPML plugins, can you please update WPML and its addons after taking site backup or let me know and I will do it https://wpml.org/account/downloads/

Thank you

March 1, 2019 at 8:51 pm #3263190

tomaszA-3

Hi Norman, yes - the website is backuped. You can proceed with any actions.

March 4, 2019 at 3:47 pm #3269708

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have run some manual & automated tests and enabled WP Debug mode as well to see if there are any php errors shown, below are the results:

- Speed test result with WPML activated: hidden link
- Speed test result without WPML: hidden link

Manually using network tab of browser:
- Dashboard Page = 4s
- Pages section = 5s
- Plugins page = 7s
- Posts section = 3.4s

I have increased WP Memory and Max Memory limit to 512MB and speed looks improved to some extent. As you can see in above results there is not much difference when WPML was activated or deactivated. There is some delay in page loading but this seems normal to me as you are using WPML and 4 of its addons handling lots of functionalities, specially String Translation. WP Plugins page is an exception and it always loads slower than the rest as it loads and checks all plugin files.
----------------------------------------

1. If you want to have more speed. There are a few things which could be implemented to improve the performance, this in turn will allow WPML to perform better as well. This includes:
- Add Expires Headers
- Leverage browser caching

To address the Expires Headers, Leverage browser caching recommendations, open the .htaccess file in the root directory of your WordPress installation and add the following:

## BEGIN Disable ETags ##
Header unset ETag
FileETag None
## END Disable ETags
 
## BEGIN GZIP Compression ##
<ifModule mod_gzip.c>
mod_gzip_on Yes
mod_gzip_dechunk Yes
mod_gzip_item_include file .(html?|txt|css|js|php|pl)$
mod_gzip_item_include handler ^cgi-script$
mod_gzip_item_include mime ^text/.*
mod_gzip_item_include mime ^application/x-javascript.*
mod_gzip_item_exclude mime ^image/.*
mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
</ifModule>
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript
## END GZIP Compression ##
 
## EXPIRES CACHING ##
<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/jpg "access 1 year"
ExpiresByType image/jpeg "access 1 year"
ExpiresByType image/gif "access 1 year"
ExpiresByType image/png "access 1 year"
ExpiresByType text/css "access 1 month"
ExpiresByType application/pdf "access 1 month"
ExpiresByType text/x-javascript "access 1 month"
ExpiresByType application/x-shockwave-flash "access 1 month"
ExpiresByType image/x-icon "access 1 year"
ExpiresDefault "access 7 days"
</IfModule>
## EXPIRES CACHING ##

2. More suggestions to improve your site speed at the link below:
hidden link

Thanks

March 31, 2019 at 7:49 pm #3502587

tomaszA-3

I really don't see any improvements. Back-end is still very slow. I am maintaining many wordpress websites (over 30) and only the one with WPML have such big speed issues. Here is a new website that I am building: hidden link. It is working on the same server as Minipizza.pl. Minipizza.pl has 50 products (200 with translations). Printmar has 600 products. They have the same template and almost the same plugins. Yet Minipizza.pl works 10x slower. The only thing that is different is that Minipizza.pl has WPML plugin installed.

April 1, 2019 at 5:04 pm #3510301

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
I'm taking this ticket again.

Could you tell me if you already applied the recommendations provided by my colleague in the site? Also, could you provide screenshots with load time before and after apply the recommendations?

Regards,
Carlos

April 21, 2019 at 6:20 am #3651745

tomaszA-3

This thread is NOT resolved!

April 21, 2019 at 1:29 pm #3652491

tomaszA-3

Here I can provide a screen with WPML ON and OFF.

April 21, 2019 at 5:24 pm #3652815

tomaszA-3

After removing "Translation Management" BS plugin all the problems are gone. Not understand why were you forcing to install it, but I hope it wasn't really needed.

April 23, 2019 at 12:11 pm #3663763

tomaszA-3

Now I see it was needed and the whole problem is back. Please reopen this thread.

April 26, 2019 at 3:03 pm #3691775

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
I'm sorry for the delayed answer.
For some reason this ticket got closed automatically but I just re-opened it so we can keep working on solving this issue.

I visited your site again and I can't reproduce the issue. The backend of the site loads correctly with no visible performance problem.

I kindly ask you to install 'Query Monitor' plugin and compare the performance between the actual installation and a minimal installation (all plugins disabled and a default WordPress theme enabled). Could you provide screenshots of both cases?

Note: If you authorize me I will be more than happy to apply the steps recommended above. For this I need you to confirm that you have a full backup of the site before I can proceed.

Looking forward to your message.
Regards,
Carlos