Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Noman 3 years, 2 months ago.

Assigned support staff: Noman.

Author Posts
November 24, 2018 at 12:55 pm #2936290

raffaellog-3

Hi,

I am trying to create a new language switcher for a menu but I get to a blank page.
I read on the forum to try deactivating plugins BUT I can't do this as for some plugins deactivate means also losing data and delicate configuration tips so, could we add this from msyql or other?
I can provide you admin access if you can support.

thank you

November 26, 2018 at 1:06 pm #2940179

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Please make sure you are using updated theme and plugins.

- Please enable error reporting at you site as I need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/
https://codex.wordpress.org/Debugging_in_WordPress

To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

define( 'SCRIPT_DEBUG', true );

This will create debug.log file in your site's wp-content directory. Please send me its contents.

Thank you

November 27, 2018 at 10:15 am #2943579

raffaellog-3

Hi Noman,

thanks for reply.
I upgraded memory limit on config but no solved. It was working with this settings I believe is due t some plugin but disabling plugin will get som data loose and site would look bad.
I enabeld al debugging stuff you asked, I can provide ftp, backend admin login, whatever you need, I really don't know how to fix.

please let me know how we can solve

November 27, 2018 at 2:14 pm #2944488

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

November 28, 2018 at 11:27 am #2947598

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for the login details. I have logged in to your site and checked menu language switcher in frontend/backend and all working fine as you can see in attached screenshots. Could you please let me know the steps to reproduce this issue.

Thank you

menu language switcher.png
frontend language switcher.png
November 28, 2018 at 12:03 pm #2947715

raffaellog-3

hi, the problem is when I click on "+ add a new language switcher to a menu", by clicking on that button I get a blank page.
I need to add a switcher on mobile menu.
Actually currently the flags switcher is disappeared from menu on my site, did you make any change?

thanks

November 28, 2018 at 4:01 pm #2949008

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Yes, I was testing few things so I removed that. I have again added language switcher in Menu. I can see now that issue is in mobile menu as it does not show any language switcher. I am working on this further and will let you know soon.

Thanks

November 28, 2018 at 4:10 pm #2949031

raffaellog-3

Hi again, the mobile menu is a different menu, it's not the same on desktop and for this menu flag switcher hasn't been created because of the problem of the blank page 🙂

thanks a lot, let me know 🙂

November 28, 2018 at 4:40 pm #2949162

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have examined debug.log file from /wp-content directory and found below error that are not related to WPML.

[27-Nov-2018 10:30:20 UTC] PHP Notice:  Undefined index: description in /home/wonder14/public_html/wp-content/plugins/js_composer/include/autoload/class-vc-settings-presets.php on line 394

I have added language switcher in desktop and mobile menus and now both menus working fine. You can customize both language switchers from WPML >> Languages >> Menu Language Switcher as you can see in attached screenshots.

If you do not want to check conflict and debug further that should be okay.

Thank you

mobile switcher.png
desktop switcher.png
backend switcher.png

The topic ‘[Closed] backend blank page on language switcher’ is closed to new replies.