This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How to change the backend language Solution: - Go to Users -> Your profile and do the following there: -- Personal Options -> Language -> English -- WPML language settings -> Editing language: -> Set admin language as editing language -> leave this option unchecked

This is the only option which controls this.

This topic contains 2 replies, has 2 voices.

Last updated by raquelE-2 3 months, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
June 7, 2019 at 1:39 pm #3976861

raquelE-2

I want my wordpress backend to be in English despite my main site to be in Spanish, before I was able to do this with no problem since the last updated that has changed so if I change my backend to English my site's main page changes to English. How can I FIX this please?

June 7, 2019 at 1:55 pm #3976941

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me if you tried the following:
- Go to Users -> Your profile and do the following there:
-- Personal Options -> Language -> English
-- WPML language settings -> Editing language: -> Set admin language as editing language -> leave this option unchecked

this is the only option which controls this ( I have just tried this on my clean WordPress installation, I've set Spanish is a default language, but by performing the steps from the above, my backend language is always English).

Regards,
Bruno Kos

July 1, 2019 at 4:31 pm #4121171

raquelE-2

My issue is resolved now. Thank you Bruno!