This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by janv-25 12 months ago.

Assigned support staff: Bruno.

Author Posts
October 15, 2018 at 12:17 pm #2817329

janv-25

I am trying to: Get a background image on every homepage of hidden link visible. Now its only visible on the default dutch language. All translated homepages doesn't have a background-image on a certain section

Link to a page where the issue can be seen:
1. hidden link
2. hidden link
3. hidden link
4. hidden link

I expected to see: that on the translated page the same background to the section with the summary is visible as it is on the dutch default homepage (see attached screenshot)

Instead, I got:a white background wich makes the summary text invisible because its white as well...

October 16, 2018 at 10:57 pm #2822518

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

How is this background being added in the primary language? Is this some option on the theme or is it some block in your page builder?

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

October 26, 2018 at 7:33 am #2852145

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I fixed your site by following the steps below:

- On the WPML > Settings > Media translation > Start button. This was necessary to duplicate the images to be used in the secondary languages.

- On the Cherry Options > Custom CSS, I added the other pages ID in your custom CSS so that the same format would be applied in the secondary languages:

.page-id-203 #post-203 .parallax-bg-inner,
.page-id-2249 #post-2249 .parallax-bg-inner,
.page-id-2254 #post-2254 .parallax-bg-inner,
.page-id-2252 #post-2252 .parallax-bg-inner,
.page-id-2714 #post-2714 .parallax-bg-inner

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

October 26, 2018 at 7:39 am #2852199

janv-25

My issue is resolved now. Thank you!