Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by julio-c.C 8 months, 2 weeks ago.

Assigned support staff: Osama Mersal.

Author Posts
March 19, 2021 at 3:09 pm

julio-c.C

I have a full WMPL license and I had installed also Toolset Types, which is freely included in the WMPL license.
Then I wanted to try the rest of Toolset components and I bought the license
After a few days I cancelled the license and ask for the refund. But now a big and intimidating warning message is appearing in my plugin administration page asking me to uninstall Toolset from my WordPress.
How can I get rid of this message. I wish to continue to use Types as part of my WMPL license as I used to do.

March 19, 2021 at 3:49 pm
March 21, 2021 at 10:30 am #8361657

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for contacting WPML forums support. I’ll be glad to help you today.

I've checked your site and saw the banner. Could you please try the following steps?
1- Take a full backup of your site
2- Uninstall toolset types and delete the cache if you use any cache plugins
3- Go to Plugins-> Add New-> Commercial tab
4- Scroll down to toolset type inside WPML plugins' table
5- Install it

Kindly try these steps and let me know if it works for you.

Thanks,
Osama

March 21, 2021 at 11:24 pm #8363469

julio-c.C

Hi Osama,

I have followed the steps you ask me to follow, but it didn't work.

After uninstalling Types the banner dissapeared from WP Admin panel (desktop) and from the plugin admin list, but it continued to appear at the bottom of the WPML plugin list (commercial), as you can see in the uploaded image.

Then I have installed Types again from this page (commercial) and the banner has appeared again in desktop and plugin list admin page... just as it appeared before uninstalling...

I do not know how to do for getting rid of that banner...

Thanks for helping me.

Captura.JPG
March 21, 2021 at 11:27 pm #8363493

julio-c.C

Sorry, I have forgotten to tell you that we do not have for now any cache plugin.

Thanks in advance

March 22, 2021 at 8:25 am #8365731

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for the update. Could you please try the following steps?
1- Go to Plugins-> Add New-> Commercial tab
2- Click on Unregister "WPML from this website."
3- Go to (https://wpml.org/account/sites/), copy the key
4- Register WPML again

Kindly try these steps and let me know if it works for you. If it didn't work, I'd escalate the issue.

Thanks,
Osama

March 22, 2021 at 12:56 pm #8367997

julio-c.C

Thanks again, Osama.

I have Unregister my website. The strange thing is that the red banner doesn't disappear at the bottom of the WPML plugin list after unregistering WPML from my website, as you can see in the attached picture...

At this moment I have my WPML registered, Types is uninstalled, the banner has disappear from Admin panel and Plugin list but is already present at the bottom of WPML plugin list (commercial). I guess that it will appear if I install Types again...

Captura.JPG
March 22, 2021 at 1:10 pm #8368093

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for trying the steps. Could you please confirm that you have a full backup of your site?

I'll try these steps:
1- Unregister WPML
2- Register WPML with a new site key other than yours and check if I'll face the same issue.

If these steps worked correctly, you might need to delete your site registration and register it again as a new site.

Thanks,
Osama

March 22, 2021 at 2:52 pm #8369399

julio-c.C

Yes I have a local copy of the site folder and I have also a .sql export of the wordpress database.

So, are you going to follow the steps by yourself? If the answer is positive, you can go ahead.

Thanks,

March 22, 2021 at 3:54 pm #8369779

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for your confirmation. Could you please restore the database? After restoring, I'll consult 2nd tier supporters regarding your issue

Thanks,
Osama

March 22, 2021 at 4:13 pm #8369929

julio-c.C

Ok. Osama. I have just restored de database. Is it also necessary to restore files folder?

If answer is not, you can now consult 2nd tier support .

Thank you for your support, Osama. Have a nice day.

March 22, 2021 at 5:04 pm #8370393

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I'm consulting the 2nd tier supporters now. I'll get back to you as soon as I get their reply.

Thanks,
Osama

March 24, 2021 at 10:17 am
March 24, 2021 at 12:52 pm #8389759

julio-c.C

The proposed procedure worked like a charm! Everything is ok now.