Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
January 8, 2021 at 11:07 am
January 11, 2021 at 11:29 am #7815267

arjanO

Hi Raja, I still need help regarding this topic. Could you send me an update?

January 11, 2021 at 1:53 pm #7816679

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am already working on this. The package is huge to get it imported on the local environment. It failed a few times, I am giving it a another try.

January 12, 2021 at 3:45 am #7821239

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I could not get the import working due to its huge size, Please send me a copy of the site Database and a copy of the sites "plugins and theme" folder compressed to an archive file. That will be much better and the size of the package will be smaller.

January 12, 2021 at 10:22 am
January 12, 2021 at 10:24 am #7823197

arjanO

Sorry I send a full backup. Can you give me a private message again? Then I can send you the version with the plugins and the theme only.

January 12, 2021 at 10:45 am #7823429

arjanO

I was able to edit the private message. So you now have two options. Either the full backup or the version with just the plugins and theme + DB.

January 13, 2021 at 9:26 am #7832317

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I could not reproduce the issue using the copy of your site, I am able to see the translated content in the fronted without any issue please check the attached screenshot.

Also i see in the test page you have used a Global template which is not translated and each global layout should be translated the same way as the page. Goto WPML > Settings >Post type translation look out for Templates (fl-builder-template) set the option to "Translatable - only show translated items " and save.

Once done, Open the template in the edit screen and hit update button this will prepare the content for translation. Click on the plus icon to add English translation for the global template (same way as you do for pages).

Let me know if you still have issues.

Regards
Raja

January 13, 2021 at 11:23 am #7833825

arjanO

Maybe the test page wasn't the best example. On most pages that are build using WooCommerce with Beaver Builder this issue is there: The translation is one box and it's not displayed on the front end. WPML translation editor: hidden link
Page Link: hidden link

January 14, 2021 at 12:38 pm #7844291

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

This is more likely a stuck translation the below steps works for me in the local installation.

1) Open the dutch product in edit page, From the url get the product id eg: 8710, refer hidden link

2) Goto WPML > Packages , Remove the entries which has 8710 as package number hidden link

3) Once removed, Update the dutch product and now you will have to add new translation for english, At this point you will be able to see all the page builder layouts

4) Finish the translation and save

Let me know if you still have issues.

Ps: Attached screenshot from local with translated English product, displaying all the missing layouts

Regards
Raja

January 15, 2021 at 7:26 am #7850377

arjanO

Hi Roja,

We hired an agency to do the translation for us. So adding a new translation for English is not really the answer I had hoped for. Is it not possible to use the existent packages that we have for translation?

January 18, 2021 at 8:02 pm #7872925

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Raja is off today so I'll be handling this ticket.

I tried to check a few settings in the test site to look if there's an alternative solution and to better answer your doubt but it seems like the credentials that used to work for us are no longer a valid match. I'm getting a "wrong username/password" error when trying to login now.

Can you please review that information and get back to us?

I’m marking your next message as private again in case you need to send us confidential data.

Thank you, please let us know.

January 19, 2021 at 6:26 am
January 20, 2021 at 4:57 pm #7890061

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

I checked this out but so far I couldn't find an alternative fix for it.

I asked my colleagues to have a look at this issue in order to see if there's anything I'm missing.

I'll come back here as soon as one of my colleagues reply back to me (which it shouldn't take long).

Thanks,

January 22, 2021 at 6:46 am #7903427

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I have sent more details to the second tier, I will keep you posted.

The topic ‘[Closed] Beaver Builder fields missing in the translation editor’ is closed to new replies.