Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Andreas W. 3 months, 4 weeks ago.

Assigned support staff: Andreas W..

Author Posts
May 19, 2022 at 7:35 pm

dannyB-14

I've installed an activated and updated version of WPML to my website: prohealthfinancial.ca and even after translating all of the 7 pages that exist on this site to French, I cannot for the life of me show the French pages. From the backend, you can clearly see that the pages are 100% completely translated, however you you load the page from the front end, you get a completely blank page.

May 19, 2022 at 8:39 pm
May 20, 2022 at 2:32 am #11261711

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

On the dashboard it says:

WPML Update is Incomplete
You are running updated sitepress-multilingual-cms, but the following component is not updated:

wpml-string-translation (required version: 3.2.0)

You can always download the latest versions here:
https://wpml.org/account/downloads/

I have tried updating the WPML plugins now for you at Network Admin > Plugins but this somehow failed, as it seems that WPML was not registered on the site.

I removed the plugins and installed our new Installer Plugins.

Then I installed the latest WPML plugins for your mentioned site.

When trying to translate the homepage, I still get an error:
There has been a critical error on this website.

The homepage appears to use Beaver Builder, but you also have Elementor activated. Is this site actually using Elementor? If not, then please disable Elementor for this site.
Also, disable any other Elementor Addons or additional plugins that are not essential (not used) for this site and test again.

Apart from that, I would suggest you adjusted the WP Memory Limit inside the wp-config.php files, as the currently assigned 64M might not be sufficient for running a site with the given amount of plugins.

If this will not solve the issue I can offer to try to create a copy of the site for debugging but it would be really helpful in this case if you could set up a staging site, in order to debug the site.

Would this be possible?

Best regards
Andreas

May 20, 2022 at 5:34 am #11262341

dannyB-14

Hi Andreas,

Thanks for the reply and suggestions, sadly after having complied to them I'm still getting the same issue.

I've tried to create a staging environment in order for you to debug, but since the site is part of a 32 multi site network, the sub site alone could not be staged, the whole network has to be and it's crashing due to the size.

So I think it's best you do the debugging on the live site, it doesn't have much traffic and I have taken a back up in case of anything.

All I ask is to make sure you stick to the subsite, prohealthfinancial.ca and if something needs to be done on the network, to please let me know first.

Thanks

May 20, 2022 at 10:05 am #11264367

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I can open the Translation Editor for the homepage now, after manually saving the French homepage, and I can confirm to see a 500 error on the browser debug console.

The error disappears and the WPML Translation Editor saves as expected once I disable the plugin "Ultimate Addons for Beaver Builder". We have not had any reported issues about the plugin - it should be compatible.

The source of the issue even could be connected to one of the network-enabled plugins.

I will try to take a copy of your site for testing or if this fails, we could try to recreate the issue on a sandbox while only using Beaver Builder PRO and Ultimate Addons for Beaver Builder after importing your pages.
Maybe I might need your assistance on this behalf in case I will not have the latest plugin version available. I will let you know.

Best regards
Andreas

May 20, 2022 at 11:27 pm #11269317

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I've tried several times to package the website with Duplicator PRO, but I get a message that the PHP setting "increase Max Build Time" needs to be increased.

I have to increase the value by typing in the htaccess file, but even that doesn't solve the problem.
The creation of the package still seems to get stuck at about 26%.

At this point please update Beaver Builder PRO and test again. You are using version 2.3.2.5 while the latest version 2.5.4.2 with and 2.6 alpha version is available as well.

hidden link

Also, make sure that Ultimate Addon for Beaver Builder is updated. You are running 1.26.3 while the latest version is 1.34.6:

hidden link

Best regards
Andreas

May 24, 2022 at 7:30 pm #11296711

dannyB-14

Hi Andreas,

Thanks for the reply and update.

The plugins have been updated and hope we can find a solution, or else I may have to simply create French pages without WPML, but I'd like to avoid that at all costs.

Regards,

May 26, 2022 at 7:10 am #11312399

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have updated the About us page in Beaver Builder and saved the page again.

Now when I open the WPML Translation Editor the translation was only completed to 57% and the whole content appears untranslated yet.

For testing purposes, I complete the translation to 100% with Google Translate and it appears that the issue is now solved, only the layout and design plus images are somehow not copied.

In order to maintain layout and design, I have set the Beaver Templates to be translatable and I would suggest you translate them too.

If this will still not solve the issue, please let me know.

Best regards
Andreas

May 31, 2022 at 10:56 pm #11357687

dannyB-14

Hi Andreas,

I'm still not understanding why this is so difficult, I've gone the route of creating French pages, but without the switcher working properly, it's quite useless. Can you please help me find a solution?

Thanks

June 2, 2022 at 3:58 am #11367709

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The language switcher is working just fine.

When working with WPML usually the workflow is to create original content in the site's default language and then translate this original content with the WPML Translation Editor.

Once the original content is updated WPML will ask you to update the translations by using the WPML Translation Editor again, and so on.

May I ask what was your workflow here?

The problem here is that you got all your pages assigned as English content.

You need assign the pages to the correct default language and connect the contents.

Some issues:
Further, now as you have French and English pages assigned to English, the English pages have been translated already and it appears, now that I was testing, that some contents seem not to be translatable with the WPML Translation Editor.

I am not sure if this is related to custom page builder widgets or untranslated templates, which is why I was asking to also translate the templates.

The fix:
I have deleted those translations now, then assigned your French pages to actually be assigned to the French language and connected them to the English original pages now for you.

Further steps:
I would anyhow suggest you keep translating the templates, for which I have already created translation jobs at WPML > Translations.

If you run into issues with translating the content with the WPML Translation Editor after updating original pages, please let us know.

Best regards
Andreas