Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Beaver builder urls on translated page link to wrong url.

Solution: Try to change the language URL in WPML → Languages → Language URL format option to Different languages in directories.

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/language-setup/language-url-options/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 26 replies, has 3 voices.

Last updated by jillS-3 11 months, 3 weeks ago.

Assigned support staff: Radu.

Author Posts
December 8, 2020 at 6:51 am #7612931

jillS-3

Beaver builder urls on translated page link to wrong url

December 11, 2020 at 4:24 am #7641139

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support.

Before your ticket is assigned to one of my colleagues, please allow me to walk you through some initial debugging steps. This will help speed up the support process.

I just checked the hidden link & hidden link links and they are showing properly for me, did you make any changes recently?

Further, We recently released a new version of WPML plugins so can you please update the plugins to the latest version and let me know if that helps.

We push out WPML releases gradually. If your sites haven’t received this update yet, give it some time and you’ll see the update in a few days.

To skip the queue and get the update right away, to the Plugins → Add New page, click the Commercial tab and then click the Check for updates button.
https://wpml.org/wp-content/uploads/2020/04/wpml-force-plugin-update-1.png

Note: Keep a Backup Before Updating

Look forward to your reply.

Thanks

December 11, 2020 at 7:12 am #7641797

jillS-3

Dear Shekhar, Thank you for helping me out! The problem is that the button links are right but on the Dutch version they (automatically, very strange) go to a different URL. In the translation sections these button links texts don't show so I can't even change them manually to the right one. Did I explain myself right?
Best regards,
Barbara

WPML DUtch version. The button link is right.png
WPML Dutch version. Button goes to wrong URL.png
wpml english version. Button goes to right URL.png
December 11, 2020 at 7:15 am #7641865

jillS-3

Oh and I didn't change anything since contacting you! Before contacting you I deleted all the buttons on the English version of the page (I never touch the Dutch version as that is in your instructions). I've added all new buttons to that page. Unfortunately this also didn't help. I saw the new button (more info) texts in the translation section but not the button links.

December 12, 2020 at 8:12 am #7649487

jillS-3

Dear Shekhar, I've updated WPML and the issue still exists :(. It feels like there is some line of code that forces almost all the buttons on the Dutch page (hidden link) to go to this URL: hidden link. Strange, isn't it?!
I really hope you can help me out! Thank you sooooo much in advance and have a nice day!

December 15, 2020 at 12:09 pm #7668341

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Jill,

I had a look at this and I have to admit that it's indeed a pretty strange issue.

However, there are a few things that you should change first.
1. As I can see, the WP memory limit on your website is 40M. Can you increase it to 128M (256M recommended - https://wpml.org/home/minimum-requirements/) and tell me if the issue is still available, please?
You can have a look at this article to find out how to make this change:
https://docs.woocommerce.com/document/increasing-the-wordpress-memory-limit/

2. Please increase the max_input_vars limit of your PHP to 10000. This is needed when the content of the page is pretty big, which happens to be your case.

Please make these two changes and check again the links. If the issue is still there after these changes, I will have another look.

Thanks,
Radu

December 15, 2020 at 3:52 pm #7670245

jillS-3

Hey Radu,
Thank you for your reply!!! The WP memory limit was already changed last week but somehow this doesn't show up at the dashboard (it still says that the Memory limit is 40 which it isn't). I've asked the hosting company to double check this. I've attached a printscreen with the current settings. They've just increased the max_input_vars limit of my PHP to 10000. I don't know or it takes time before there is any result? Unfortunately, the strange problem is still there...
I hope you can help me out and have a nice day!
Best regards,
Jill

Hostnet update memory.png
December 15, 2020 at 4:01 pm #7670319

jillS-3

Hi Radu, what is especially strange it is not the same at all the horses. With some horses the link does work. Maybe this gives you an indication of what can go wrong?

December 16, 2020 at 11:04 am #7676255

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Jill,

Thank you for telling me about the links, that sometimes they are working. Now I tried to what the difference between the links that work and the ones that are not.

I checked again the WP memory limit and the value of the Max execution time, and they are not changed. You can check these values in WPML → Support area. In this case, can you first make sure that these are changed as I asked to make sure that this is not the source of the issue, please?

Also, do you have any module of optimization/caching installed on your website? I'm asking for this because I tried to make a change on the translated page here:
hidden link

by manually changing the link of the SCARLINA DE TIJI Z (MARE) horse, but the link is not changing on the frontend (please see the attached screenshot). The link is still hidden link even if, as you can see in the screenshot, I changed it (and I'm using the default WordPress editor).

Thanks,
Radu

Screenshot 2020-12-16 at 13.02.12.png
December 16, 2020 at 12:16 pm #7677055

jillS-3

Hi Radu,

First, thanks for looking again!

Now the strange thing is at the hosting company because I 3-double checked with them and they say the memory is 100% changed (see my earlier screenshot). Can it be that this not visible in the WPML → Support area. Can that be the problem??? That somehow that memory is not well 'coming through'? Is there any way I can confirm the memory is changed without contacting the hosting company so I can check if they are right (they are a big reliable company but just to be sure...)

I'm using Buiver Builder as an editor and there I can clear the cache 'Settings → Buiver Builder →Tools → Clear cache'. The plugins I have installed are here: hidden link. Can the security or firewall plugin maybe be a problem? When you want you can deactivate all plugins to check (except Buiver Builder, Yoast, Password protect and WPML).

And yes, that with the link is the problem. Whatever I tried (and I tried a lot before contacting your company even make a different page), the link is always hidden link. Very strange, isn't it?!

Hope this helps you further and again thanks for helping me out with this strange challenge...

December 16, 2020 at 2:23 pm #7678085

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Jill,

I checked the Tools → Site Health area, which is from WordPress (not from WPML):
hidden link

and, as you can see under Server, the PHP max input variables is still 5000, and the value of WP_MAX_MEMORY_LIMIT is 1024M, just like WPML is showing in WPML → Support area. This means that our plugin is reading the right values.
I'm not trying to defend WPML or anything like that, it's just a double check that I made by comparing the values from WPML with the ones from WordPress.

Thanks,
Radu

December 16, 2020 at 3:02 pm #7678473

jillS-3

Hi Radu,
I'm for sure not thinking you want to 'proof' your right. You are actually helping me a lot and I love WPML and always use it at other sites!!! I will contact the hosting company again and show them the site health info and again the WPML info. Hopefully, they take it seriously now (I already contacted them 4 times and they assure me things are ok) as maybe there is an issue on their side. Please wait with investigating until you hear back from me!
Best regards

December 16, 2020 at 3:05 pm #7678477

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Jill,

I'll be right here once you make these changes, to have another look if the issue is still available 🙂

Thanks,
Radu

December 16, 2020 at 4:34 pm #7679441

jillS-3

Hi Radu,

I'm really really sorry (!) and hope you can understand this... at the hosting company they just made me adapt everything myself in the '.user.ini' file so I could check it for myself.
There it says now (copy-paste):
memory_limit = 512M
max_input_vars = 10000
upload_max_filesize = 128M
post_max_size = 128M
max_execution_time = 300
BUT at the WPML info it still says that the memory limit is 40. At Site Health it says it is 1024 which is also not right as it should say 512M. And at Site Health it also says that max_input_variables: 5000 while I made it 10000 (see the 'copy-paste' above). So maybe here is something going wrong??? Or is the hosting company fooling me (can be of course ;). Or can it be that the editor (Beaver Builder) is blocking things? I used this editor a lot in combination with WPML but maybe they've changed something?

Meanwhile, I've tried another trick and copied the template of the hidden link page and added all the content to a brand new page. In English, all goes well and in Dutch (hidden link) ALL the buttons NOW go to hidden link (so refreshing the page). So it shows the same behaviour but the (wrong) URL is magically changed to another one (from hidden link to hidden link. Funny things are happening here :)). Are there WordPress ghost we have never heard about? But maybe this gives you a clue on where things go wrong... Do hope so!

December 16, 2020 at 9:05 pm #7681029

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Jill,

I can see that the two values are still not changed on your website. In this case, I still have one more ace in my sleeve.

Please have a look at my previous message here:
https://wpml.org/forums/topic/beaver-builder-urls-on-translated-page-link-to-wrong-url/page/2/#post-7681019

Basically, what I did is create a safe place where you can make a copy of your website and where I can control these two values. As I mentioned in my early messages, increasing the memory limit and the max input vars does not guarantee that will fix the issue, it's just a change that did the trick for other users with a similar issue.

Since we can't make these changes on your website, let's create a copy of it by following the steps that I presented in my previous reply. If changing the two values that I mentioned will make things go back to normal, then you'll need to reach out again to your hosting.
However, we can jump over this back-and-forth discussion with the hosting so let's find out what's the source of the issue on the cloned website.

Once the migration is done, please create again the page with the URLs again, on the migrated website, translate it, and tell me how things work this time.

Thanks,
Radu