This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Lauren 3 months ago.

Assigned support staff: Lauren.

Author Posts
May 15, 2018 at 9:29 am #2133891

Karl

I have a header template build with Beaver Themer version 1.1.1.1
Translated in 15 languages.

Full site visable, for all users.

With WMPL disabled, the header is showing frontend, but enabling WPML the header disappears.

May 16, 2018 at 12:57 pm #2157511

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

This is an older issue that should be resolved with the version of Beaver Themer that you are using. So, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except Beaver Builder, Beaver Themer and WPML related and then temporarily change the theme to the default Beaver theme (currently it looks like you have a cusotm theme). With these settings, is the issue resolved?

May 16, 2018 at 2:36 pm #2159928

Karl

Hi

I have tried that without any success.
Copied this site to a testing environment: hidden link

Disabled all plugins, except Beaver Builder, Beaver Themer and WPML.
Also switched to Beaver Theme, so no child theme.

Header is not showing, and 'footer bar' which is a themer part, had now become a header.

May 16, 2018 at 3:01 pm #2160191

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Could you please share access to the testing site so that I can further troubleshoot? You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

May 16, 2018 at 3:19 pm #2160344

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks so much for providing access. I have escalated this to our Compatibility team, and I can see that our developers have been in touch with Beaver Themer authors and are working towards making these compatible. I will update here as soon as I have more information.

May 17, 2018 at 3:03 pm #2178227

Karl

next problem:

when saving page, form the translation editor, the screen keeps saying: 'saving...'
takes about a minute (see screenshot) before it eventually closes the page as being saved

I have all plugins disabled except wmpl and beaver plugins
memory setting: 512MB

May 17, 2018 at 3:32 pm #2179018

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Karl, for the new issue, please open a new ticket. This will help other users with similar problems find solutions when searching the forum as well as we avoid mixing lots of questions in one ticket.

Thank you for your understanding.

July 16, 2019 at 6:14 pm #4223101

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

This issue is currently resolved for Beaver Themer supported themes, for example WPOcean.