This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Dennis 5 months ago.

Assigned support staff: Dennis.

Author Posts
May 7, 2019 at 8:45 pm

aaronJ-5

I set a header in Beaver Builder Themer to apply to the Home Page. (Some other pages will have a different header.)

I visit the site, the header shows up. I switch the language to French, the header goes away and shows the default Genesis header.

The password to view the site under development is: tdt

topdogtours.com

May 8, 2019 at 4:00 am #3763799

aaronJ-5

As an update I have removed the Genesis header markup altogether and assigned one Themer header to be site wide. This way pages that don't have a header assigned yet will show the 'default' header from the Themer, not from Genesis.

However, the main issue remains... when I switch language it shows the default header that I set to be site wide rather than the header that is assigned to the page where the change was made.

For example: hidden link

This section of the site has the "New York" header assigned to it and all children. When I switch the language to French it shows the Home 'default' header, not the New York Section.

May 8, 2019 at 6:24 am #3764065

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

I can see the issue on your site. I would like to request your permission to install Duplicator plugin, build a package and download a copy so I can continue debugging locally and without affecting your site. Please let me know if I can proceed.

Thank you.

Kind regards,
Dennis

May 8, 2019 at 12:16 pm #3766525

aaronJ-5

Hello Dennis,
No problem, please proceed. I am going to roll the site back to a previous state as Beaver Builder support was also working on the site. I will do this right now, so please wait for 15 minutes to do your work.
Regards,

Aaron

May 9, 2019 at 1:38 am #3771791

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I tried to access your site but the credentials does not work anymore on my end. Could you please check.

Thank you.

Kind regards,
Dennis

May 9, 2019 at 1:44 am #3771807

aaronJ-5

Hello,
Sorry, the user was deleted, please try now.
Regards,
Aaron

May 9, 2019 at 2:19 am #3772065

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

I have successfully created a duplicator package. I will download a copy and try deploy it on my local machine. Then I will continue debugging your site on my test environment and will give you feedback when I got some results.

Kind regards,
Dennis

May 9, 2019 at 3:30 am #3772727

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Could you try these steps and check if it resolves the issue?

-On WPML > Settings > Post Types Translation, set 'Themer Layouts (fl-theme-layout)' to 'Translatable - only show translated items'

-On WPML > Settings > Custom Fields Translation, click 'Show system fields'
-search for the custom field '_fl_theme_builder_locations' and set it to 'Translate'
-Save.
-edit the the theme layout. edit it on the original language.
-translate the theme layout. You should have the ID field in the WPML editor to add the ID of the translated posts/pages which the theme layout should appear.

Does it help? Please let me know how it goes.

Kind regards,
Dennis

May 9, 2019 at 4:09 am #3772957

aaronJ-5

Hello I accidentally clicked Duplicate instead of Translate and can't go back, how do I get the edit button back from duplicated?

May 9, 2019 at 4:23 am #3773049

aaronJ-5

I followed your steps for the Spanish version, however I don't understand where to put the ID's so I skipped that step, but the Spanish version started working somehow anyway. The French version does not work.

The Spanish version works on the home page, but it does not work on the New York City Page. If I switch to Spanish while on the New York City Page it shows the Home Page menu.

May 9, 2019 at 1:48 pm #3776663

aaronJ-5

I may have made progress on this... I reset WPML and then did the steps as you suggested, but it didn't work. Then I translated the home page then synced the menus. Then in the Themer Layout editor : Add location rule, the translated home page was an option, so I added it and now the menu appears on the home page when in the French language.

May 10, 2019 at 3:20 am #3780945

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your update.

It seems that you can actually translate page rule in secondary language using manual translation. To do that please try these steps:

-edit the theme layout. edit it in default language.
-now, switch to secondary language using the language switcher located on the admin bar.
-change the pages (french pages) which the theme layout should appear.
-save.

Does it help? please let me know.

Kind regards,
Dennis

May 13, 2019 at 12:13 am #3794039

aaronJ-5

Thank you, I had to work on some other things. But I will update here when I get back to this and verify that everything is working.

May 13, 2019 at 1:16 am #3794099

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

No worries. Please just take your time and let me know how it goes.

Thank you.

Kind regards,
Dennis

May 20, 2019 at 12:15 am #3842817

aaronJ-5

I'm still working on this.