This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to translate but when i do a translation with WPML translator I see duplicate fields.

Solution: Make sure that the Builder | Data Storage option from the theme Advanced section is set to Serialized (and not to Encoded).

Tagged: 

This topic contains 14 replies, has 3 voices.

Last updated by raquelC-5 1 month, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
August 7, 2019 at 12:43 pm

raquelC-5

I am trying to:
translate but when i do a translation with wpml translator i see duplicate fields
i'm working with betheme template and muffinbuilder.

Link to a page where the issue can be seen: hidden link

August 7, 2019 at 2:11 pm
August 7, 2019 at 2:24 pm #4355937

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Raquel,

before we test this in a Sandbox environment, could you please try to make the languages first available under WPML -> Languages?

"Idiomes del lloc
Aquests llenguatges estan habilitats per a aquest lloc:
Cat (predeterminat)
Eng (amagat)
Esp (amagat)"

It could be that the Muffin Builder is duplicating the field because the language code is blocked. Maybe you need to update after this the default language. Please let me know.

Best Marcel

August 7, 2019 at 4:27 pm #4356807

raquelC-5

Hi!
Ok i made the languages available.
The issue continue...

August 7, 2019 at 4:42 pm #4356935

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Raquel,

thanks for the info. Could you please test if you can reproduce the same issue on an isolated Sandbox environment? You please need to upload Theme and Muffin Builder and create a page from scratch with the identical settings (One page is enough).

WPML is already pre-configured like on your site. hidden link

Please let me know

Best Marcel

August 8, 2019 at 6:40 am #4359997

raquelC-5

Hi!
Ok it's do it!
On your link there is the theme with the same settings and a page "el metode" with identical settings.
Also I send you a coupple of imatges:
When i export the settings of "el metode" (image n.1) from our web the theme give me a code to export and copy. This code is the same that i see on the translation options (image n.2)
And another thing, In happykids.cat we changed the theme name from betheme and betheme child (folder name and in style.css) as you can see in image 3 and 4. I don't know if this last point is important!

thanks a lot!

August 9, 2019 at 6:46 am #4367743

raquelC-5

Hi!
I've tested the page "el metode" and activated the same wpml plugins on the sandbox.
But i haven't any field to translate!. Also i've changed the settings of "mfn-page-items" from "custom field translation".
I look forward to your response.
thanks a lot!

August 9, 2019 at 12:59 pm #4370471

raquelC-5

#4356935 any news about that?
thanks!

August 9, 2019 at 2:00 pm #4371025

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Raquel,

Sorry for the delay.
The page was not translated with "+" on the Sidebar. I did this now. Could you please check the page now?

hidden link

Best Marcel

August 9, 2019 at 2:14 pm #4371087

raquelC-5

#4371025 Ok now i see all the fields!
Usually I translate with "+" but from the list of pages.

August 9, 2019 at 4:20 pm #4371863

raquelC-5

Hi! maybe the base64 code can be changed in this advanced setting (see image)?

August 12, 2019 at 1:22 pm #4381281

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Raquel,

no problem, the function on "Pages" & on the Sidebar is the same.

Yes, the Encoding comes from here.

#1 Please change it to "Serialized" (without save mode)
#2 Save the page again
#3 Open the translation Editor

Best Marcel

August 19, 2019 at 7:32 am #4414003

raquelC-5

hey!
thanks and sorry for the delay!
we are on holidays ,we return next monday! I'm going to confirm the solutions next monday!
thanks

August 19, 2019 at 10:00 am #4415015

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Raquel,

Marcel is on holidays too so I'll handle this ticket.

Please enjoy your holidays first and then give me a message back once you're back to the computer. Just let me know how the change suggested by my colleague is working.

Wish you a fab one,
Radu

August 28, 2019 at 11:23 am #4473837

raquelC-5

Hi! I checked and seems that is working ok!.
thanks a lot!
5stars