This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: User was not able to setup BetterAMP with different languages in folders. Solution: This was fixed by the BetterAMP team in this commit https://github.com/better-studio/better-amp/commit/bbb185334a48cc200abcae89a59d14aa48f9bff8

This topic contains 24 replies, has 3 voices.

Last updated by David marka 5 months, 2 weeks ago.

Assigned support staff: Jamal.

Author Posts
March 27, 2019 at 10:19 am #3469505

David marka

i have problem about BetterAMP for WPML ,for frontpage(English) amp working
but when select another frontpage(France or arabi or ...) not working not open page.
how can fix it?
please help me how do fix it.
thank you

March 27, 2019 at 5:23 pm #3474253

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

1. Can you please give me the links that you are referring to? (the one that works and the one that doesn't work) Also, can you please try to elaborate what do you mean when you say that it doesn't work? If you also have some screenshots, that would help a lot, too.

2. From what I can see, the BetterAMP plugin is not part of our official WPML-compatible plugin repository here (https://wpml.org/documentation/plugins-compatibility/). However, that doesn't necessarily mean that the plugin is not compatible with WPML but there might be incompatibilities.

3. In order to analyze things better, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

4. In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Kind regards,
Mihai Apetrei

March 28, 2019 at 8:07 pm #3485423

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

When I try to log in using the credentials that you shared, it is not working (I am attaching a screenshot).

Can you please verify again and click "Edit" on the post above and introduce the working credentials?

I will be waiting for your response.

Kind regards,
Mihai

March 30, 2019 at 2:35 am #3495969

David marka

please check again

March 31, 2019 at 2:59 am #3500041

David marka

hello dear support,
did you check ?
i waiting you reply me
thank you...

April 1, 2019 at 6:59 pm #3511065

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hello.

Sorry for the late response but I don't work on the weekends.

I tried to log in again but it still doesn't work.

I will attach the screenshot.

Can you please check and re-add the working credentials below? I am activating the private fields once again.

Kind regards,
Mihai

April 4, 2019 at 8:16 am #3533039

David marka

did u check again??!??

April 4, 2019 at 10:18 am #3533883

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I can confirm that the credentials are working now and I was able to log into the backend.

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

2. It seems that the situation you are confronted with is the exact one from the ticket here: https://wpml.org/forums/topic/language-urls-are-not-working-in-amp-pages/

The actual reason of the issue is this one:
https://wpml.org/forums/topic/language-urls-are-not-working-in-amp-pages/#post-1416399

So after you go to WPML > Languages and change from "Different Languages in directories" to "Language name added as parameter", things start to work properly as you can see in the screenshot I attached here (just load this link after you change that setting: hidden link).

Can you please follow the recommendations of my colleague in the ticket above?

That should make AMP work.

Kind regards,
Mihai

April 6, 2019 at 3:52 am #3548413

David marka

i know but i want my site URL /ar/ or /fa/ or /fr/
not ?lang=fa
how can fix it ? please help
thank you.

April 6, 2019 at 5:38 am #3548455

David marka

thats why i use URL (/fa/ or /fr/ or /ar/) because seo in google set it.cant again problem more about 404 or 410 anything page.thats bad my site. i need fix it about it URL default
thanks for understand me

April 8, 2019 at 10:01 am #3556375

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Mihai is not working today, so i will take care of this post for the moment.
As he already stated, the plugin is not compatible with WPML and it is clear that it does not handle the /fr/ /fa/ etc... correctly.

What i can suggest, is trying in the minimal setup(minimum of plugins and default theme), so i created a test server, please install better AMP, configure one more language and reproduce the error. If reproduced i will approach our compatibility team for a fix, but this could take time as i cannot decide on their prioirities.

Let me know you would like to proceed so ?

Best regards,
Jamal

April 9, 2019 at 3:51 am #3562905

David marka

Hello Dear Support, (Jamal)
i need fix it ,and let u be proceed for fix about AMP my site...thanks for help me

April 9, 2019 at 7:53 am #3563875

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Please reproduce this issue on our clean server and we will investigate the origin of this issue. The login info to our server were provided in my message at (APRIL 8, 2019 AT 10:01 AM).

The "Better AMP" plugin is not listed on our compatibility list, which means we are not sure if it will work with WPML or not.
https://wpml.org/documentation/plugins-compatibility/?wpv_view_count=119945&dev=0&wpv-plugin-functionality=0&wpv_post_search=amp&wpv_filter_submit=Search

We need to reproduce this error on our clean install, which will exclude any other origin to the issue. Then we can push it through our compatibility process.

Looking forward to your reply.

Best regards,
Jamal

April 13, 2019 at 2:37 am #3602859

David marka

i still wait u for support be proceed for fix about AMP(BetterAMP) my site...thanks for help me

April 15, 2019 at 10:40 am #3612539

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

As suggested before. Either you switch your language format to language in parameters or help us pass the plugin through our compatibility process.

Our compatibility states that the plugin should go through our clean install. If the issue is reproduced through it, it means it is not caused by other things which may exist in your website.

Without your collaboration on this issue, we maintain our suggestion: switch to language in paramters.
Looking forward to you reply.

Best regards,
Jamal