If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 28 replies, has 2 voices.

Last updated by Bigul 1 year, 1 month ago.

Assigned support staff: Bigul.

Author Posts
September 18, 2018 at 2:34 pm #2745434

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Have you made any changes in the site or server settings? Because I am not able to reproduce the issue on your site now. Please check the attached images and let me know your feedback.

--
Thanks!

Bigul

September 19, 2018 at 8:05 am #2747671
benjaminS-17

Hello,
I do not know if the problem is still there but it is true that it's been 2 days the problem has not occurred. I just put the PHP version of the server in 7.0.
But I'm not sure that the problem is solved.

I have another question, when I'm in the Google search console I have a problem.
When I request the indexing of the home page: hidden link Google tells me that there is a redirection to hidden link while he there is none. Also when I type in google (French) AromaCare the metadescription below the site is in English while google shows the / en.

Could you help me

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/split-big-problem-error-500/

September 19, 2018 at 8:32 am #2747815

benjaminS-17

And the same problem for the shop.
hidden link google tell me that redirect to /en/shop

September 19, 2018 at 2:41 pm #2749100

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. The issue may be happening because compatibility issues of the server configuration with PHP 5.6. Because it works on my local server with PHP 5.6 and 7.1. Please watch it closely and make sure the issue is happening again or not.

I have opened a new ticket for the Google search console issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. I will get back to you soon on the new ticket. Please wait. Thank you for the understanding.

--
Thanks!

Bigul

September 24, 2018 at 6:50 am #2759465

benjaminS-17

Hello, I understand for the new ticket.
For the old problem, he came back.
I do not know what to do, but it seems that for the website to work again, you have to deactivate then any plugin.

Thank you

September 24, 2018 at 3:29 pm #2760988

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I went through most of the pages and products in French and English(including the checkout page). But it is not showing Internal Server error. Therefore please let me know in which pages you having the issue now.

Please share more details about the following for a better understanding.

but it seems that for the website to work again, you have to deactivate then any plugin

--
Thanks!

Bigul

September 25, 2018 at 6:50 am #2762607

benjaminS-17

The problem has not changed. After an indefinite period, certain pages of the site are deactivated as: hidden link hidden link hidden link
You do not see it because as soon as I see the problem I repair to prevent the site from being offline.
To correct the problem I just have to disable any plugin and then reactivate it.

September 25, 2018 at 7:11 am #2762760

benjaminS-17

I paid a developer to find the mistake. Here is his answer:

The bug is caused by WPML and the woocommerce-checkout-manager plugin. The strings of the woocommerce-checkout-manager plugin are stored in the database so that they can be translated by wpml, except that there was a bug when creating its data in the database and it missing some values needed by WPML. When he looks for a translation for these values, he falls on the poorly formatted record and crashes the page.
I just checked, there is more badly formatted record (I repaired one yesterday, and one at the moment). If this were to be repeated, we would have to see with the WPML editors what causes this bug on their side.

September 25, 2018 at 2:46 pm #2764318

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have forwarded the details to our second tier team for the expert opinion and waiting for their feedback now.

I have one more request. Please increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links and attached image for more details. Then make sure the issue is existing or not.

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

--
Thanks!

Bigul

September 26, 2018 at 7:30 am #2766137

benjaminS-17

Hello,
WP limit memory has been upgrade.
Here you can find the error, when the problem appears :
[25-Sep-2018 12:51:00 UTC] PHP Fatal error: Uncaught InvalidArgumentException: Translation name cannot be empty in /home/aromacarvs/v2/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php:107
Stack trace:
#0 /home/aromacarvs/v2/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php(44): WPML_ST_Page_Translation->validate_values('26493', '', 'woocommerce-che...')
#1 /home/aromacarvs/v2/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/persist/class-wpml-st-page-translations-persist.php(107): WPML_ST_Page_Translation->__construct('26493', '', 'woocommerce-che...', '', false, '')
#2 [internal function]: WPML_ST_Page_Translations_Persist->create_translation_from_db_record(Array)
#3 /home/aromacarvs/v2/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/persist/class-wpml-st-page-translations-persist.php(51): array_map(Array, Array)
#4 /home/aromacarvs/v2/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/persi in /home/aromacarvs/v2/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php on line 107

September 26, 2018 at 12:09 pm #2767133

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have shared it with our second tier team and waiting for the response now. We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

September 26, 2018 at 5:33 pm #2768292

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, I have tried to reproduce the issue on my local server. But the following error is not showing in the *debug.log* file. Also, the string with ID is not existing the String Translation table(in the database). Therefore please let me know the exact steps to reproduce the issue.

PHP Fatal error: Uncaught InvalidArgumentException: Translation name cannot be empty in

--
Thanks!

Bigul

October 8, 2018 at 7:28 am #2794909

benjaminS-17

The developer with whom we worked, blocked the writing of the plugin in the database. So normally the problem does not happen anymore.

October 8, 2018 at 9:00 am #2795216

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Are you still having the *Error 500*? Because we are still not able to reproduce it here. If you are still having the issues, please let me know the exact steps to reproduce the issue. Thank you for the understanding.

--
Thanks!

Bigul

The topic ‘[Closed] Big Problem error 500’ is closed to new replies.