This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 14 replies, has 2 voices.

Last updated by cristinao-2 3 weeks, 5 days ago.

Assigned support staff: Noman.

Author Posts
September 12, 2019 at 2:15 am #4557189

cristinao-2

Hi!
I have an issue, my site is in Italian and all works good, but in the English version it shows a black bar on the header; can You help me, please?
Many thanks!!! 🙂

September 12, 2019 at 4:55 am #4558351

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have tried to open your site but your site seems to be coming soon state that’s why I couldn’t see this issue.

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 12, 2019 at 2:49 pm #4561983

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have logged in to your site and compared both pages page options and found out that translated page 'Enable Transparent Header' and ‘Enable Header Padding’ option have a default value. I have fixed this issue by following below steps:

1. Wento to WPML >> Settings >> Multilingual Content Setup >> Custom Fields Translation.
2. Set the ‘basix_transparent_header’ and ‘basix_header_padding’ boxes fields as Copy.
3. Updated default language page.

And now settings looks synchronized in each language. Could you please check and confirm?

If you want to keep exact page layout on all languages:
- Either you can duplicate original page to secondary language and then translate text of secondary page.
- Or you can mark page settings fields to as copy from WPML >> Settings >> Multilingual Content Setup >> Custom Fields Translation so that it will maintain the same value in both pages.

Please let me know if this resolves your issue or you need further assistance.

Thank you

September 12, 2019 at 11:24 pm #4564419

cristinao-2

You are fantastic Noman!!! Thank You!!!
Now I can fix every page and I've learned it for future websites, thank You so much!!!!

September 12, 2019 at 11:25 pm #4564425

cristinao-2

My issue is resolved now. Thank you!

September 13, 2019 at 12:07 am #4564481

cristinao-2

I am really sorry to disturb you again!
The instructions worked on 2-3 English pages, but when I try to fix the others (the machines), it doesn't keep the settings and the black bar is there again (when I edit again in fact the options are not checked); am I doing something wrong? I'm clicking on "Enable Padding" and "Enable Transparent Header"

September 15, 2019 at 8:24 am #4574167

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Could you please provide me pages link where I can see this issue.

Thank you

September 16, 2019 at 12:20 pm #4580071

cristinao-2

Sure!
/automatic-seamer-f60/?lang=en
/automatic-seamer-f60v/?lang=en
/automatic-seamer-f70/?lang=en
/automatic-seamer-f120/?lang=en
/automatic-seamer-b40l/?lang=en
/automatic-seamer-b60l/?lang=en
/automatic-seamer-b120/?lang=en

September 16, 2019 at 4:38 pm #4582673

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have fixed this issue in these pages:
/automatic-seamer-f60/?lang=en
/automatic-seamer-f60v/?lang=en

Here you can see a video of the steps that I followed to fix this issue.
[video removed]

I hope it helps, Thank you

September 16, 2019 at 4:45 pm #4582703

cristinao-2

Thank You! (I'm so moved You've also made me a video, really!)
This is exactly what I did, but on some pages works, and not in the one listed before; it's like WP doesn't keep memory of the edits I do 🙁

September 16, 2019 at 5:20 pm #4582861

cristinao-2

I also tried to change computer but WP keeps me only the Padding option, not the transparent header one; I am really sorry to ask You more time, but can You do it for me please?

I really can't understand why it doesn't keep it, I tried to delete the cache too (in WP and in browser) but it's always the same 🙁

September 17, 2019 at 9:20 am #4586975

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have followed the same steps on all provided pages and now these pages not showing black bar anymore.
Could you please check and confirm?

Thank you

September 17, 2019 at 2:23 pm #4589133

cristinao-2

Thank You so much Noman!
THIS IS FAR MORE THAN ASSISTANCE, I'm so grateful, thank You!!!

September 17, 2019 at 8:00 pm #4590919

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I am happy to hear that I was able to help you 🙂 Can you please mark this ticket as resolved and leave some rating about the support you received from me?

Thanks

September 20, 2019 at 4:58 pm #4613707

cristinao-2

Of course! You are the greatest!!!

My issue is resolved now. Thank you!