This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Riffaz 3 months, 3 weeks ago.

Assigned support staff: Riffaz.

Author Posts
June 23, 2019 at 6:27 pm #4073479

Attila Bontovics

I am trying to: update wpml plugins

Link to a page where the issue can be seen: hidden link

I expected to see:

Instead, I got: blank page

I cant provide debug info, because when i activate sitepress-multilingual-cms plugin, i got blank page ... so i cant check debug info box...

June 24, 2019 at 6:25 am #4074879

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Debugging
1. Please follow the debugging information provided here: https://wpml.org/documentation/support/debugging-wpml/#enabling-the-built-in-debugging-feature-in-wordpress.
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know.

Regards,
Riffaz.

June 25, 2019 at 10:08 pm #4087323

Attila Bontovics

Hi,

Here is debug report:

[25-Jun-2019 22:04:07] PHP Parse error:  syntax error, unexpected T_CLASS, expecting T_STRING or T_VARIABLE or '$' in /var/www/vhosts/rollingcars95.com/httpdocs/travel/wp-content/plugins/sitepress-multilingual-cms/inc/functions.php on line 810
[25-Jun-2019 22:04:08] PHP Parse error:  syntax error, unexpected T_CLASS, expecting T_STRING or T_VARIABLE or '$' in /var/www/vhosts/rollingcars95.com/httpdocs/travel/wp-content/plugins/sitepress-multilingual-cms/inc/functions.php on line 810 
June 26, 2019 at 8:00 am #4090239

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

This could be either plugin files are corrupted or you are using the older version of PHP

Could you please let me delete the current WPML plugin, download the latest copy from https://wpml.org/account/downloads/ and reinstall?

If that does not help check your php version.
WPML requires PHP 5.6 or higher.

Let me know.

Regards,

The topic ‘[Closed] Blank page after update’ is closed to new replies.