This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I am trying to configure the WPML plugin, at 3rd step there is a blank page.

Solution:
I have enabled error logging at your site and it’s showing following errors in debug.log file inside wp-content folder.

[09-Oct-2018 10:03:11 UTC] PHP Fatal error:  Uncaught Twig_Error_Runtime: No suitable convert encoding function (use UTF-8 as your encoding or install the iconv or mbstring extension). in /home/lookon/public_html/wp-content/plugins/sitepress-multilingual-cms/templates/language-switcher-admin-ui/layout-main.twig:18
Stack trace:
#0 /home/lookon/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Extension/Core.php(1234): twig_convert_encoding('\xC5\x9B', 'UTF-16BE', 'UTF-8')
#1 [internal function]: _twig_escape_html_attr_callback(Array)
#2 /home/lookon/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Extension/Core.php(1095): preg_replace_callback('#[^a-zA-Z0-9,\\....', '_twig_escape_ht...', 'To jest kolejno...')
#3 /home/lookon/public_html/wp-content/uploads/cache/wpml/twig/4a/4abb0e40eb009bf5d540b66fa04082b7c111c48a8bd16302f1aa7d46bbfd8b48.php(20): twig_escape_filter(Object(Twig_Environment), 'To jest kolejno...', 'html_attr')
#4 /home/lookon/public_html/wp-content/plugins/sitepress-mult in /home/lookon/public_html/wp-content/plugins/sitepress-multilingual-cms/templates/language-switcher-admin-ui/layout-main.twig on line 18

You can fix this issue by enabling mbstring from PHP settings. You need to contact your website hosting support and let them know to enable this for your server / site.
https://wpml.org/home/minimum-requirements/

Relevant Documentation:
https://wpml.org/forums/topic/some-settings-have-disappeared-after-i-switched-the-url-format-of-the-language/#post-1365377

This topic contains 3 replies, has 2 voices.

Last updated by marekT-4 1 year ago.

Assigned support staff: Noman.

Author Posts
October 6, 2018 at 11:21 am

marekT-4

I am trying to configure the WPML plugin, at 3rd step there is an blank page.

I was trying to unactive all other plugins but it won't help fix the issue. I was trying to switch the theme to the default, it didn't help uswell.

Link to a page where the issue can be seen:
hidden link

October 8, 2018 at 5:03 pm #2796997

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

=== Please backup your database and website ===

- If you are configuring WPML first time and do not have any translated data then you can fix this issue by removing WPML and all its data completely from database, To do so, please go to WPML >> Support >> Troubleshooting (the link is at the bottom of the support page). >> There, click on “Reset and deactivate WPML” >> then Delete the plugin.

- After delete all data and WPML related plugins then please install WPML plugins again and I hope now you will not face any issue.

- If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Sixteen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

- If above does not resolve the issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

October 9, 2018 at 7:51 am
October 9, 2018 at 11:44 am #2799759

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have enabled error logging at your site by adding following code in your site’s wp-config.php file:

 // Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

And it’s showing following errors in debug.log file inside wp-content folder.

[09-Oct-2018 10:03:11 UTC] PHP Fatal error:  Uncaught Twig_Error_Runtime: No suitable convert encoding function (use UTF-8 as your encoding or install the iconv or mbstring extension). in /home/lookon/public_html/wp-content/plugins/sitepress-multilingual-cms/templates/language-switcher-admin-ui/layout-main.twig:18
Stack trace:
#0 /home/lookon/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Extension/Core.php(1234): twig_convert_encoding('\xC5\x9B', 'UTF-16BE', 'UTF-8')
#1 [internal function]: _twig_escape_html_attr_callback(Array)
#2 /home/lookon/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/twig/twig/lib/Twig/Extension/Core.php(1095): preg_replace_callback('#[^a-zA-Z0-9,\\....', '_twig_escape_ht...', 'To jest kolejno...')
#3 /home/lookon/public_html/wp-content/uploads/cache/wpml/twig/4a/4abb0e40eb009bf5d540b66fa04082b7c111c48a8bd16302f1aa7d46bbfd8b48.php(20): twig_escape_filter(Object(Twig_Environment), 'To jest kolejno...', 'html_attr')
#4 /home/lookon/public_html/wp-content/plugins/sitepress-mult in /home/lookon/public_html/wp-content/plugins/sitepress-multilingual-cms/templates/language-switcher-admin-ui/layout-main.twig on line 18

You can fix this issue by enabling mbstring from PHP settings. You need to contact your website hosting support and let them know to enable this for your server / site.
https://wpml.org/home/minimum-requirements/

There has been some reports similar to yours and was able to solve it by enabling mbstring:
https://wpml.org/forums/topic/some-settings-have-disappeared-after-i-switched-the-url-format-of-the-language/#post-1365377

Thank you

October 9, 2018 at 2:00 pm #2800339

marekT-4

My issue is resolved now. Thank you!