This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 9 voices.

Last updated by benjaminM-26 2 years, 9 months ago.

Assigned support staff: Dat Hoang.

Author Posts
December 17, 2016 at 1:41 am #1162736

michelK-8

I am trying to: open any page of my site using HTTPS.

URL of (my) website where problem appears: internal

I expected to see: the page without error in the Security Console of the browser (Firefox), all WPML CSS files are loaded usign HTTPS.

Instead, I got:
Blocked loading mixed active content “hidden link

Steps to duplicate the issue:
- open a site with WPML and SSL
- check the Security Console of the browser
- the error shows
- view the source of the page, the /templates/language-switchers/legacy-list-horizontal/style.css file is included usign HTTP, instead of HTTPS.

December 17, 2016 at 8:50 pm #1162910

Ramiro

Same here michelK-8

It would be useful if WPML support could at least tell us what's the file doing that call, at least to manually update the file.

December 17, 2016 at 9:21 pm #1162916

shayL

Same here... /wp-content/plugins/sitepress-multilingual-cms/templates/language-switchers/legacy-list-horizontal/style.css?ver=1'
remains http, so the style for my language selector is borken.

Bad for business i cannot move my clients to https and they are angry.

December 19, 2016 at 9:04 am #1163339

Dat Hoang

@michelk-8:
It seems this happens very specific to your sites.

I don't have this issue on my site (running in https).

Can you please go to wp-admin -> Settings -> General, and take a screenshot here? Please make sure all of them are set to https.

@others: Can you please open other tickets? And refer this ticket?
Each ticket we support for one client only. Instead, you can subscribe and see our discussions.

December 20, 2016 at 2:01 am #1164275

michelK-8

wp-admin -> Settings -> General, WordPress and Website (URL) are both set to HTTPS.

Issue remains. It appeared after I activated WPML. The issue is not specific to my site, as more users are facing it. We plan to go live these days.

Would you have a good idea on how to make the CSS file loaded via HTTPS?

hidden link

December 20, 2016 at 3:40 am #1164310

Dat Hoang

#1,
I tested but there is no issue on my site. Then, this might be a compatibility issue rather than a bug in our code.

If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

#2,
Please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

December 28, 2016 at 1:29 pm #1169947

michelK-8

#1
We disabled ALL plugins except of WPML Multilingual CMS, the issue remains. The following error still shows on any page load:

Blocked loading mixed active content hidden link

When we disable WPML Multilingual CMS and leave all other plugins enabled, the issue is still there.

The above findings also apply when using Twenty Sixteen theme.

Therefore this is NOT a compatibility issue. This is also NOT an issue specific to our site, as several other users are facing it.

Would you have a good idea on how to make the /language-switchers/legacy-list-horizontal/style.css CSS file loaded via HTTPS? Maybe you can explain which WMPL script is responsible of generating this code:

<link rel="stylesheet" id="wpml-legacy-horizontal-list-0-css" href="hidden link" type="text/css" media="all">

#2

debug information provided with this reply

December 29, 2016 at 4:00 am #1170473

Dat Hoang

Thanks for your all info.

Can you please do this? Remove this folder wp-content/cache/wpml/ and refresh your page.
Does that help?

If not, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

This info is private and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:
+ Backup (both files and database) your site before giving us your credentials
+ It would be better if you give me the test site rather than the live site.

We'd like to request the permission to disable, enable and install themes and plugins for this site. Please accept this?

January 2, 2017 at 1:31 pm #1172517

indushaN

Hi,

I'm having the same problem.

Changing theme and then switching back to the theme we want to use solves the issue.

However on our server, the wp-content/cache folder does not exist.
Does WPML has some other sort of caching?

January 6, 2017 at 11:17 am #1176047

michelK-8

The folder wp-content/cache does not exist on our site. Is this an issue about caching?

Our site is in the intranet, not accessible to you, unfortunately.

Update: when we disable WPML Multilingual CMS and leave all other plugins enabled, the issue DISAPPEARS, independent of the theme used. When we disable all other plugins and keep WPML Multilingual CMS as the only active plugin, the issue APPEARS, independent of the theme used. When we keep all plugins activated, including WPML Multilingual CMS, the issue APPEARS, independent of the theme used.

Changing theme (by switching to Twenty Sixteen) and switching back to our theme does not help in our case.

We are not happy with WPML support at this moment.

Could you explain which script is responsible of generating this code?

<link rel="stylesheet" id="wpml-legacy-horizontal-list-0-css" href="hidden link" type="text/css" media="all">

January 7, 2017 at 12:08 pm #1176580

jornv

I am having the exact same issue. Everything on my site is loaded over https exact for the above stylesheet.

Disabling "backwards" compatibility (since the stylesheet has legacy in its path) does not seem to help either.

Version running is 3.6.1.

January 9, 2017 at 7:20 am #1177000

Dat Hoang

@michelk-8: Please provide us your site credentials like what I asked in my recent reply above.

NOTE: this private info is available to you and our supporters ONLY.

----

For other clients in this thread, please help us to do these:
1. Delete this folder "/wp-content/cache/wpml" on your site, and refresh your site.
2. If the issue still exists, please open new tickets for your own.

We recommend subscribing to get update here. However, please discuss with us in your own ticket(s). That enables us to support all of you better and more efficiently.

January 9, 2017 at 8:17 am #1177044

Dat Hoang

FYI: Please try this setting.

Go to WPML -> Support -> The "Troubleshooting" page, or directly hidden link

Then, select "Enable cache for language switcher templates".

January 12, 2017 at 3:57 pm #1180889

jornv

Does clearing the cache of WPML have any nasty side effects I should know of before doing so?

January 13, 2017 at 8:27 am #1181345

michelK-8

Selecting "Enable cache for language switcher templates" did not help.

The site is in the company intranet, not accessible from outside. Providing the site credentials as you requested is not useful.

Any other suggestion? More users are facing the same issue and this case is open for a month almost ...