This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Bruno Kos 4 months, 4 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
February 22, 2019 at 9:00 am #3231422

desireeD-2

Hi,

I installed the ACF 5.8 beta 3 plugin, which introduced an interface to create Gutenberg Blocks. So, I created custom Gutenberg blocks with ACF, works fine in the primary language. The custom blocks are not translatable, however - they do not appear in the WPML translation editor. There are also no options "not translate/translate/copy/copy once", as there usually are with regular custom fields.

On this page, WPML states that this issue has been resolved:
https://wpml.org/errata/gutenberg-blocks-created-using-acf-5-8-are-not-translatable/

Are there any special settings in WPML that I need to make in order to make Custom Gutenberg blocks created with ACF translatable?

Thanks,
Bnejamin

February 22, 2019 at 2:56 pm #3232884

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Are you referring to custom blocks created like this?
https://wordpress.org/gutenberg/handbook/designers-developers/developers/tutorials/block-tutorial/writing-your-first-block-type/

Or Gutenberg default blocks?

Also, have you seen this info:
https://wpml.org/documentation/support/language-configuration-files/#gutenberg-blocks

Let me know so that we can check this out in our Sandbox.

Regards,
Bruno Kos

February 25, 2019 at 2:39 pm #3240340

desireeD-2

Hi Bruno,

no, I am talking about custom blocks created with the Advanced Custom Fields plugin (5.8), as related to on this page:
https://wpml.org/errata/gutenberg-blocks-created-using-acf-5-8-are-not-translatable/

Thanks,
Benjamin

February 26, 2019 at 9:37 am #3243816

desireeD-2

Hi Bruno,

thanks for setting up the sandbox, but I cannot create the same scenario, because in order to do this, I would need to create new template files via FTP or SSH. Also, I cannot grant you access to my server, as it is an internal test server.

So I probably will try to contact the people from Advanced Custom Fields plugin, maybe they can help.

Benjamin

February 26, 2019 at 9:39 am #3243825

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

That is not a problem - find WP Sandbox menu item within the sandbox, you'll find SSH and SFTP credentials in case you'll need these.

Regards,
Bruno Kos

February 26, 2019 at 11:26 am #3244472

desireeD-2

Hi Bruno,

ok, thanks. I tried something different:

1) In the Advanced Custom Fields plugin, I translated the complete custom block field group using "duplicate" as described here:
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#translating-acf-user-interface
2) Then I translated the page that contains the field group, also using "duplicate" and using the normal WordPress Gutenberg editor (not the WPML standard translation editor).

-> Now I was able to translate the custom blocks created with the ACF plugin.
-> However, the custom blocks do not appear in the WPML standard translation editor, and they do not appear if I do choose the "duplicate" option.

I'll try to reproduce this in the sandbox.

February 26, 2019 at 1:22 pm #3245069

desireeD-2

Hi Bruno,

I have now created the same scenario in the sandbox. There is a custom Gutenberg block called "Test Block" and an ACF field group with the same name. I can add and edit the new custom block in the Gutenberg editor, and the custom block is rendered in the front end.
But this custom block does not appear in the WPML translation editor, so I can't translate it.

Can you see the problem?
As you can see, regular Gutenberg blocks are translatable in the standard WPML translation editor.

Benjamin

February 26, 2019 at 2:25 pm #3245364

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Yes, I can see the issue now, even if we set "Translation preferences" to Translate for these (on each field), they don't appear in TE. I've escalated this to 2nd tier and will get back to you as soon as I hear from them.

Regards,
Bruno Kos

February 27, 2019 at 8:22 am #3248835

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

This has been escalated to 2nd tier now, I'll get back to you as soon as I have any news or questions for you.

Regards,
Bruno Kos

February 27, 2019 at 8:43 am #3249001

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It seems that errata was marked as resolved mistakenly. This issue is still being handled and we're waiting for more work to be done from ACF author.

Regards,
Bruno Kos

February 28, 2019 at 9:12 am #3254273

desireeD-2

Hi Bruno,

glad to hear that you could reproduce/see my problem. Thanks and I hope that thinks work out soon.

Cheers,
Benjamin

February 28, 2019 at 10:06 am #3254528

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

(changing Ticket status for internal purposes - please ignore)

May 22, 2019 at 7:55 am #3862703

desireeD-2

Hi Bruno,

on this page (https://wpml.org/errata/gutenberg-blocks-created-using-acf-5-8-are-not-translatable/) it says that the issue should have been resolved by now.

However, I am still not able to translate ACF Custom blocks. I have latest ACF 5.8 installed, Advanced Custom Fields Multilingual 1.3, WPML Translation Management 2.8.5, WordPress

The ACF custom blocks do not appear in the WPML translation editor, they do not appear if I try to translate in the WordPress editor. The custom fields within the ACF block are not even listed in WPML > Settings > Custom Fields Translation.

Basically, nothing has changed since I opened this thread.
Any settings I have to make/change?

Thanks,
Benjamin

May 22, 2019 at 9:45 am #3863843

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I was able to get them working for translations and here is how I did it:
- registered a custom block using this code:
hidden link
- Set "Show this field group if" -> Block for testimonial (see image)
- Added one field and for Translation preferences I set "Translate"
- Added this block in Gutenberg and added a text (see image)
- Created translation and the field is there

Can you tell me if this is the scenario you're after?

What comes to my mind that you haven't set "Added one field and for Translation preferences I set "Translate" or perhaps that you need to make any minor change on the original, click update and try translating then.

Regards,
Bruno Kos

May 22, 2019 at 10:33 am #3864367

desireeD-2

Hi Bruno,

ok, here is what I missed: I have a multisite installation running. The underlying problem is that the "Translation preferences" are not displayed when editing a field group, so the field group was probably set to the default setting "Don't translate".

So I googled this and stumbled across this thread:
https://wpml.org/forums/topic/acfml-1-1-not-displaying-translation-preferences-in-custom-field-group/

The "solution" in this thread was to change the code of the ACFML plugin:
https://wpml.org/forums/topic/acfml-1-1-not-displaying-translation-preferences-in-custom-field-group/#post-3555819

I did this, and now I can translate custom blocks.

However, modifying the plugin code is not a satisfying solution. The thread mentioned above referred to version 1.1 of ACFML, I have version 1.3 installed, but the problem with multisite installations still persists. Is there a reason why this has not been implemented in v1.3 by now?

Thx,
Benjamin