This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 32 replies, has 3 voices.

Last updated by Bruno 6 months ago.

Assigned support staff: Bruno.

Author Posts
February 6, 2019 at 5:09 am #3164248

gregoryN

I am trying to: translate a normal post with gutenberg blocks. I typed all the translation in the advanced editor.

Link to a page where the issue can be seen:
hidden link

expected to see: the translation

Instead, I got: nothing translated

When I go back to the advanced translator I see my translation. Also the preview doesn't show me the blick structure but only text

February 6, 2019 at 7:00 am #3164346

gregoryN

I tried several things waiting for support answer.
Tried to swich to the classical editor.
I have the same problem the translation in French is visible in the editor... But Is not saved it the gutenberg block... Therefore, it doesn't show on rhe frontend...
However íf I update the blocks directly in WordPress backend it will work ok...

February 6, 2019 at 5:38 pm #3166970

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

I would be very happy to help you but I didn't fully understand what is the issue. In Advanced Translation Editor can you see your translation correctly? How did you do the translation, manually or authentically?

Is your server using any caching system? If so, have you tried clearing the cache? Also, did you save the translations? I'll attach an image for you to see.

Can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Thank you.

February 7, 2019 at 3:39 am #3168483

gregoryN

Hi Bruno you're right my description of the problem was not clear

1. I typed my translation and saved it. I copy the screen here. Screenshot 103059 103113 and 103130
2. The translation doesn't show in the backend in the WordPress editor neither on the front end. Screenshot 103716

3. I tried a few things already: deactivate all other plugins, empty the cache (I use swift performance light) and same problem.
4. When I switch wpml settings to "translate manualy" and edit from there, the translation is saved
5. I also copy the screen of the advanced editor preview that doesn't show the block structure as expected Screenshot 103130

Thanks for your help in advance
Greg

February 7, 2019 at 7:51 pm #3171988

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. This could be some problem with this page. Does this same problem happen with other pages?

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

February 11, 2019 at 9:14 am #3181548

gregoryN

Hi Bruno
Are you working on the website right now ?
I encountered some weird behaviour of the administration for nearly 30min ?

February 11, 2019 at 10:43 am #3182214

gregoryN

I just got this message

We have detected a problem with some tables in the database. Please contact WPML support to get this fixed.

User kompozit_chti already has more than 'max_user_connections' active connections
Array
(
[language] => en
[context] => WP Endpoints
[gettext_context] =>
[domain_name_context_md5] => 78ee8a99b4d75b5ac73b36a3917b22f5
[name] => edd-remove
[value] => edd-remove
[status] => 0
[translation_priority] => optional
[allow_empty_value] =>
)

February 11, 2019 at 5:45 pm #3184737

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Please, my sincere apologies for the delay in answering. I'm going to start working on your site now. Are you still seeing the warning message you posted above?

From what I've noticed you're using classic translation now. How are you setting up these old posts to use the ATE? Are you setting this within the WPML configuration pages, or are you doing this in any other way?

Also, please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

Thank you.

February 11, 2019 at 11:50 pm #3185705

gregoryN

Hi Bruno,

1. The warning disappeared, it was a caching pb I solved.

2. For the old posts that are translated now, I used manual translation to translate them.
I switched back to classic editor within the global settings, but you will see that the problem is the same: with the classic or advanced engine, the translation I type is not copied in the blocks on the French side.

3. Yes you can install duplicator...

4. I live in Vietnam, this also explains the delay in my answers, when you work on the site I'm usually sleeping already 🙂

Regards

Greg

February 12, 2019 at 9:04 pm #3190936

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for the explanations. We have released a new version of WPML plugins today and this is likely to fix this problem.

Please, could you update all the WPML plugins and test again? Note that it is recommended to back up your site before updating your plugins.

Thank you.

February 13, 2019 at 4:50 am #3192112

gregoryN

Hi Bruno,
the problem is not fixed

I created a second post after update

as you will see in the backend, the title has been translated ok
the paragraph block on the other hand hasn't

It's been about one week already that I opened the support ticket, when can I expect having a fix on this problem ?

Thanks in advance for finding quickly the solution

February 15, 2019 at 7:50 am #3203155

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Bruno is currently offline but i will continue testing this issue so we can continue debugging it to resolve it.

I currently do not have access to install an additional plugin or even review the current activated plugins on the site , if possible please provide me with this access or install the plugin cloudways migrator so i can migrate your live site to our staging environment on cloudways to continue testing without interfering with your live environment .

additionally , please correct me if i am wrong , the issue here is that when you use the Advanced Translation Editor (ATE) the translations will not show up neither in the front end nor in the backend , but when you use the "translate manually" option the translations work as expected ? ?

are you currently hosting your site on WpEngine ?

February 15, 2019 at 8:47 am #3203475

gregoryN

Hi Bobby thanks for the follow-up

I'm hosted by OVH France

Regarding the access I created administrator credentials for Bruno which allows you to install any duplicator plugin.

However, I'm working on it right now, so should you install or copy anything, just tell me so I can stop doing things while you're copying the site.

There is a live chat on the website through wich you can text me live

February 15, 2019 at 8:49 am #3203481

gregoryN

Sorry I forgot to anwse your last question

Manual translation is ok

Classic and advanced engines give the same result, the translation doesn't appear neither on back nor frontend

February 18, 2019 at 6:57 pm #3213821

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thanks for the feedback.

At the moment it is not possible to install any plugins because as your site was created as "multisite", then only those who have access to the main site can install plugins. You can see that in the "Plugins" menu there are no subitems to install plugins. I'll attach an image for you to see.

I'm still confused by the way you're translating the content. I accessed the first post as an example and when I click to edit the translation the page displays the same editor (Gutenberg), but in French.

By its description, this seems to be a caching problem, but ideally, I should have to test in my test environment to see if the problem persists on another server. In the meantime, you can try disabling all non-WPML plugins and verifying that the problem persists. If yes, most likely this is a cache problem with your server.

Also, have you tested the problem you reported above (A variable mismatch has been detected), to see if the problem persists even with plug-in updates?

Thank you.

The topic ‘[Closed] Blocks not translated in gutenberg’ is closed to new replies.