This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Mihai Apetrei 4 months, 4 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 16, 2019 at 10:13 am #3824529

cecileL-3

Hello, here is my problem :

I have a main blogposts page in English where you can see all my blog posts : hidden link

As of yesterday, I could switch language with the WPLM menu switch and see the translated version of my blog and blogposts.
Now today, instead, I see empty pages : hidden link (French) and hidden link (german). You can clearly see that the posts are not visible, even though I can still the translated posts in my wordpress dashboard.

I have tried switching settings in Appearance > Customize > Homepage settings > Posts page
The problem is :
When I select my blog page in French for instance and validate, it makes the English one disappear. My french posts appear on hidden link but then my english posts are gone on hidden link

It's like the blog posts page can only be on one language at the time!

This is a nightmare.

May 16, 2019 at 10:22 am #3824571

cecileL-3

Also when I use the language switcher on my blog, it no longer redirects me to the translated blogpage but to the translated language homepage...

May 16, 2019 at 11:01 am #3825167

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I would be more than happy to take a look.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 16, 2019 at 5:45 pm #3828463

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Unfortunately, I am not able to log into your site's backend.

It continuously showing me the message in the 2 screenshots I attached below.

Can you please check the credentials once again and introduce them in the private fields that I am enabling below?

Thank you.

Kind regards,
Mihai

May 17, 2019 at 3:22 pm #3835581

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Now it shows me this (attached screenshot).

This is because you are using WordPress on WordPress.com (and not a self-hosted version of WordPress) and it is asking for your WordPress.com account access.

And whenever I go to "hidden link" and introduce the information that you gave me, it tells me that the credentials are not good - probably it recognizes an IP change or maybe there's some kind of security in place.

Please get in touch with the WordPress.com support (hidden link) - they are amazing and they should answer really fast on the live chat option.

Tell them that you need support from the WPML team but what you are sharing with me doesn't work.

You can also show them the screenshots I sent you.

After that, please get back to me with the working credentials.

I am enabling the private fields once again below.

Just a note that I don't work on the weekends so I will be able to get back to you at the beginning of next week.

I will be looking forward to your answer.

Kind regards,
Mihai

The topic ‘[Closed] Blog homepage only work one language at a time’ is closed to new replies.