This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by antonL-5 5 months, 2 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 29, 2019 at 6:43 am #3700273

antonL-5

I am trying to: when writing a blog, I need to upload images. I can choose them, but they are not uploaded. When seeing other blog posts, the images are also not visible. The only image that is visible is the main image.

Link to a page where the issue can be seen: hidden link TURNED OFF ALL WPML PLUGINS SO ISSUE NOT VISIBLE

I expected to see: hidden link

April 29, 2019 at 1:46 pm #3703997

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI there,

Thanks for your patience, Please increase the max input var to a limit of 5000, You can either ask your hosting provider to help you with this or in case if you can handle it from your cpanel follow the instruction in the link => hidden link

Once update goto WPML > Support under Info PHP section make sure the Max input vars values is updated.

Please let me know if this helps.

Kind regards
Raja

April 29, 2019 at 2:04 pm #3704147

antonL-5

Hi Raja,

I changed the max input var to 5000 and saved everything, but still no images.

April 30, 2019 at 4:55 am #3707869

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the update. I have requested the second tier of supporter to have a detailed look into the issue. I will update you as soon as i hear from them.

Kind regards
Raja

April 30, 2019 at 9:54 am #3710203

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I can confirm the issue with ACFML 1.2, the issue is escalated to the developer.

We have a workaround which solves your issue until the fix is released in the upcoming update.

You might need to add a minor modification in the Acml plugin file, Please let me know if you can handle it by yourself or you need any assistance in this case.

Opent the file "class-wpml-acf-attachments.ph" using FTP located in the path \wp-contet\plugin\acfml\classes\class-wpml-acf-attachments.php

Around line 13 change the code below

if ( is_serialized($value) ) {

to

if ( is_serialized($value) || is_array($value) ) {

I have tested this in my local setup using your duplicator package. I hope this would solve your issue as well.

Kind regards
Raja

April 30, 2019 at 10:04 am #3710243

antonL-5

Thanks a lot Raja, it's working like a charm!

Just one question: do I have to delete the piece of code after the update that will come or will it be solved automatically?

Thanks again for your great help, really appreciate it!

April 30, 2019 at 10:19 am #3710315

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Glad it solved your issue.

Regarding your question, If the next update of ACFML comes with the fix you don't have to do anything, it will be solved automatically.

If the fix for some reason not included in the upcoming update which is uncertain, you might have to apply the fix (the piece of code) again.

I hope it's clear 🙂

Kind regards
Raja

April 30, 2019 at 11:01 am #3710523

antonL-5

My issue is resolved now. Thank you!

May 11, 2019 at 3:15 pm #3790831

antonL-5

FYI: after updating, this line of code was vanished. I had to add it again.

May 17, 2019 at 2:05 pm #3835117

antonL-5

One week later, I had to add the code again for a second time. Can you please add this in the next update? Thanks.