This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Shekhar Bhandari 5 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 26, 2019 at 4:56 pm

antonL-5

I am trying to: when writing a blog, I need to upload images. I can choose them, but they are not uploaded. When seeing other blog posts, the images are also not visible. The only image that is visible is the main image.

Link to a page where the issue can be seen: hidden link TURNED OFF ALL WPML PLUGINS SO ISSUE NOT VISIBLE

I expected to see: hidden link

Instead, I got:

April 27, 2019 at 6:29 am #3694663

antonL-5

I've never waited so long for a solution, is something going on?

April 27, 2019 at 12:28 pm #3695417

antonL-5

There was showing somebody would take care of this ticket 30 minutes ago. But I see nothing happening. Please advise, this is an urgent issue.

April 29, 2019 at 3:42 am #3699919

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

Sorry for the delay in replying. The reply time will be back to normal now.

I can see that you haven't used media translation plugin yet, somehow I suspect that the media are uploaded have improper language creating the issue, we can fix these following the below two steps, so could you please try it and let me know how it goes?

#1
- Enable WPML Media Translation Plugin
- Go to WPML -> Settings
- At the bottom of the page on "Media Translation" Section
- Check the all available option and click on start.
This will basically add correct language information to the media files and duplicate media in all languages. (Duplicate media only creates a duplicate of entries in the database, it doesn't duplicate the media file itself)
- Wait until the process will be finished, once finished, check the issue.

Documentation Link: https://wpml.org/documentation/getting-started-guide/media-translation/

#2
Could you please go to WPML-> Support ->Troubleshooting and click the below buttons:

+ Clear Cache in WPML
+ Set Language information
+ Fix element types collation
+ Remove ghost entries from the translation tables
+ Assign translation status to duplicated content
+ Set language information

Look forward to your reply.

Thanks

April 29, 2019 at 6:24 am #3700215

antonL-5

Hi,

Followed all your instructions, but it's still the same.

I used to work without WPML Media before because it gave a bug. Reinstalled it, but the images still don't show up.

April 30, 2019 at 11:43 am #3710687

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I replicated your site on my localhost using the duplicator package available on the site and once replicated I went to WPML->Settings->Post type translation and set Media (attachment) to "translate" and it seems to be working, so could you please check if this helps?

Look forward to your reply.

Thanks

The topic ‘[Closed] Blog images not showing’ is closed to new replies.