We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 5 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 24, 2019 at 12:25 pm #3884657

aliD-9

I am trying to: have a translated version of all my blog posts

Link to a page where the issue can be seen: hidden link

I expected to see: that if i duplicate all my categories and blog post that they would be seen directly in the dutch version of my website

Instead, I got: I dont see anything

May 24, 2019 at 4:25 pm #3886237

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */
- Go to WPML -> Support -> Trobleshooting link -> Click on the troubleshooting options pointed out in the attached image.

Note: Please don't forget to make a full backup of the site before making any change. This is for security reasons.

Could you tell me if the issue persists after the steps above?

Kind regards,
Carlos

May 28, 2019 at 1:20 pm #3907355

aliD-9

Hi Carlos,

Thanks for your reply. I've increased the PHP memory limit to 128 mb. Unfortunately it's still not working. Now 1 post is visible instead of 0. Since i've published 3 posts on the dutch page they should be all visible right?

You can take a look at the page here: hidden link

Can you tell if im doing something wrong here?

Cheers,

Ali

May 28, 2019 at 7:29 pm #3909747

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Ali,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

May 29, 2019 at 8:23 am #3913013

aliD-9

Hi Carlos,

Actually it is working, but has a delay of a couple of hours. So whenever im posting something it takes some time before it's visible on the dutch version of the website. Is this normal?

May 29, 2019 at 11:15 am #3914695

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I suspect that this can be caused by some outdated cache memory. Also I recommend you to contact your hosting provided and let them know about this behavior.

Regards,
Carlos

May 30, 2019 at 11:41 am #3922725

aliD-9

Hi Carlos,

Thanks for your reply. I've got in contact with my host provider and they told me that they can not solve this problem for me but that i should talk to you guys. At the end i would say everything is working well, except for the fact that it takes at least half a day before changes in the translated pages are updated. How can i fix this outdated cache memory?

Cheers,

Ali

May 30, 2019 at 11:51 am #3922799

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Ali,
Thank you very much for your message.

WPML doesn't affect the timing of the publications, the only cache memory generated by WPML can be flushed in WPML -> Support -> Troubleshooting link -> 'Clear the cache in WPML' button.

At this point I can only suggest you to flush WPML's cache memory and check if the issue persists and in case the issue persists then test with a minimal installation (all plugins deactivated except WPML ones and a default WordPress theme active), if the issue disappeared in this minimal install, then start activating the theme and the plugins one by one until the issue appears again.

Regards,
Carlos