Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.95 hours from now. Thank you for your understanding.

This topic contains 7 replies, has 3 voices.

Last updated by John-Pierre Cornelissen 1 year, 11 months ago.

Assisted by: Dražen Duvnjak.

Author Posts
March 28, 2022 at 2:27 pm #10894231

John-Pierre Cornelissen

I have a problem on the website anakblitar.nl that seems to be related to WPML.

In the WP reading settings, you can specify what the blog page is. That should be empty on this site, but this has somehow been switched to the contact page, and when I try to change it back to empty and save, it keeps on reverting back to the contact page as you can see in this screen cast hidden link

The problem is solved when I deactive the 2 WPML plugins, which makes me think it is WPML related, although I don't see this issue on any of my other websites with WPML.

I have created a temporary 'blog page', which can be selected as a workaround to 'solve' the problem, it's ok to have that page as a draft, but as soon as I delete it, the settings switch back to the contact page again.

I'd say there is an issue with the postid of the contactpage, but that is 2 which is a normal value and doesn't cause issues on other sites.

I have no clue as to since when this is. According to the revision history the contact page was last changed on Januari 2 and back then it was ok.

Do you have any idea what the problem might be and how I can fix it?

March 28, 2022 at 3:34 pm #10894979

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, JP.

Please get back to us here when you have checked the debug.log. One of our supporters will continue helping you if needed.

Regards,
Itamar.

March 28, 2022 at 4:40 pm #10895437

John-Pierre Cornelissen

Thanks Itamar,

I checked,
- no error in de WP debug log
- no error in the serverlog

In the database in the options table, the record with option_name = page_for_posts holds the value 0 after you save the setting with '- Select - '. In that case, the reading settings show the name of the contact page (which has an ID of 2, not 0) and the contact page shows the blog role (but with an error because there is no blog post).

Edit and save the contact page doesn't fix it.
Resaving the perma settings doesn't fix it.
Resaving the WPML settings doesn't fix it.
Database maintenance doesn't fix it.

March 29, 2022 at 7:51 am #10899337

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hello,

thanks for getting back.

I will be taking over and helping further.

To troubleshoot this issue without affecting your site I created a test server for you in Cloudways (https://wpml.org/hosting-partner/cloudways/).

If it is OK with you, we can migrate your content there to further debugging without any risk on your end.

To do the migration please follow simple steps from my next private reply.

March 29, 2022 at 10:02 am #10900639

John-Pierre Cornelissen

Hi, I migrated.

Can't give the admin credentials because I can't reply privately.

I could login and then wanted to disable login reCapcha from Wordfence but when I wanted to save it, it gives a database connection error. So something isn't right there.

To reproduce
- delete the 'blog page'
- then see the screen cast in my first message.

Thanks
JP

March 29, 2022 at 1:14 pm #10902583

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hello JP,

thanks for getting back.

Sorry for that, I have enabled private reply for you now.

Please share credentials so I can login and check further.

Kind regards,
Drazen

March 30, 2022 at 7:38 am #10907693

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hello,

thanks for getting back.

I have checked and managed to fix the issue, you can now save "Select" and it doesn't revert to the Contact page.

Video:
- hidden link

Steps I took:

- Disable all plugins except for WPML plugins

- Switch to the 2020 theme

- Go to WPML > Support > Troubleshooting > Clean up and click to run next:

- Clear the cache in WPML
- Remove ghost entries
- Fix element_type collation
- Fix WPML tables collation
- Set language information
- Cleanup and optimize string tables

Feel free to log in to the migrated website and check.

I hope I was helpful. Don't hesitate to ask if you find any problems along the way, I'll gladly help you.

Regards,
Drazen

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.