Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Otto 4 years, 10 months ago.

Assigned support staff: Otto.

Author Posts
August 24, 2016 at 2:07 am #1018109

jonathanF-3

See this url (topic got marked "solved" too fast): https://wpml.org/forums/topic/cant-change-header-image-in-showcase-pro-theme/

Same URL as the other topic

Not able to find/translate text "continue reading" and "by" in the blog page. Why are these string not visible again in the string translation screen ?

August 24, 2016 at 7:17 pm #1020263

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello again 🙂

As far as I understand this is a different issue, right? The other's ticket problem is solved or you are having any issue with those strings?

Can you provide me access again to your site so I can check the issue?

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

Kind Regards,

Otto

August 26, 2016 at 2:42 pm #1024540

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I'm still checking the issue.

Thanks for your patience and cooperation.

Just a quick check: you need the comments string there? I noticed that there is no comments form in the individual post page. Is removing the string a suitable option for you?

Let me know about this please.

Kind Regards,

Otto

August 26, 2016 at 6:05 pm #1024814

jonathanF-3

Hi, you were right, I've disabled the "comment" string, so no longer need to have it translated. However, when we clic on the blog preview to read the full blog post, there is still 3 translation I can't find :
Header -> "by"
Footer -> "Filed under" and "TAGGED WITH"

Why are all these string so hard to find ? 🙂 I feel I will spend 3 hours on something that should have taken 5 minutes..... 🙁

August 26, 2016 at 7:31 pm #1024874

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

You are absolutely right. In most cases, it takes five minutes.

But sometimes is harder to find where the strings are coming from and the how to translate them.

Anyway, for the case of "Filed under" and "TAGGED WITH" they are available to translate in WPML > String translation. I used the search box to locate them and they are under the domain "genesis". In my local copy of your site, I managed to translate them without problems. Can you please try it and let me know if you find any issue?

Regarding the "BY" it seems to be part of the admin texts of the Genesis Simple Edits plugin.

So, to locate it search for this string "[post_date] By [post_author_posts_link] [post_comments]". Then you just need to translate the "By" part and it should work fine.

Let me know if it's all fine now.

Kind Regards,

Otto

August 31, 2016 at 3:53 pm #1047139

jonathanF-3

Hi Otto

The "BY" translation doesnt work. I've been able to locate the string & translate it in the dashboard, but the change isn't reflected on the front-end.

August 31, 2016 at 7:27 pm #1047434

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I'm seeing a strange behaviour on your site, that I can't reproduce in my local copy.

If on my local copy of your site, I go to Genesis > Simple Edits > Entry Meta (above content) and change By to Par or to something else and save the changes are saved and take effect on the front end.

But on your live site, these changes are not saved and of course, don't take effect on the front end.

Can you please try the following:
-Deactivate WPML for a moment
-Edit the Genesis > Simple Edits > Entry Meta (above content) shortcode
-See if the changes are saved and take effect on the front end
-Reactivate WPML and rescan the Genesis Simple Edit plugin
-Check if the shortcode string appears to be translated in WPML > String Translation

If this does not help, I need you to do a reliable and restorable backup of your site and allow me to do some tests on it. I'm truly sorry for this, but locally it works fine so I can't debug because there is any bug 🙁

Let me know your results, please.

Kind Regards,

Otto

August 31, 2016 at 8:04 pm #1047503

jonathanF-3

This seems to be related to WPRocket. Looks like WpRocket conflict with these settings : I was able to make it work by following your instructions (Deactivate all WPML plugins, edit the the entry meta, check if it take effect on the front end (yes), then re-translate the string) : Working.

BUT

As soon as I reactivate the WPRocket plugin (which was desactivated) problem occur again. You might want to test that 🙂

August 31, 2016 at 8:12 pm #1047568

jonathanF-3

Ok, another update : It's NOT related to WpRocket. I just did a refresh of the page and the change reverted.

I now also lost the 2 translation at the bottom of the post "Tagged with" and "Filed under"

August 31, 2016 at 8:28 pm #1047574

jonathanF-3

I have a ManageWP backup I can send if you need it

August 31, 2016 at 9:03 pm #1047609

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

It will be better if I can do some tests on your site. As I mentioned, I do replicate your site locally and I did manage to translate that shortcode locally. So I think is something in your live site.

So, if you allow me and if you have a reliable backup that you can restore if something unintentionally breaks I will do some tests there. If not, I'll make a new copy of the site to see if I can reproduce the issue locally.

I'm truly sorry for the inconveniences and really appreciate your cooperation and patience.

Kind Regards,

Otto

August 31, 2016 at 9:13 pm #1047641

jonathanF-3

Yes you can test on the live site if you need. Just let me know quickly if anything goes wrong.

September 1, 2016 at 11:53 am #1053233

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

After a few tests, I found that it was necessary to empty the WPRocket cache.

After that, I was able to change the option in Genesis > Simple edits and translate it in WPML > String Translation. It looks fine in the front end (BY / PAR)

As far as I can see, the whole it is working properly. Can you please check it and let me know if I missed something?

Kind Regards,

Otto

September 1, 2016 at 11:59 am #1053263

jonathanF-3

Ok I can see it, but as soon as I'll clear the cache again, problem will re-appear. On question, how are the string translation managed VS another plugin like loco translate ? Is there a .po/mo file created ?

September 1, 2016 at 2:37 pm #1053641

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Are you having issues with the cache? I checked your site and it seems fine still.

String translations are stored in the DB. You can export/import .mo files, but when using string translation (WPML -> Theme and plugins localization > Translate the theme and plugins using WPML's String Translation) it uses the DB.

WPML and Loco Translate does not play well together. Is not a compatible plugin. What do you need it for? Maybe WPML might help.

Anyway, may I kindly ask you please to open a new ticket for your new question? This way we will be able to help you better and also help other users with similar problems find solutions when searching the forum.

Thank you!

Kind Regards,

Otto

The topic ‘[Closed] Blog string translation’ is closed to new replies.