This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
The Blurb Links in the Editor - Divi theme

Solution:

Add this code to <strong>WPML > Settings > Custom XML Configuration</strong>. After that, go to the edit screen of the page (original language), do a small modification and save.
<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>et_pb_jt_material_blurb</tag>
            <attributes>
                <attribute>title</attribute>
                <attribute>image</attribute>
                <attribute>image_alt</attribute>
                <attribute>body</attribute>
                <attribute type="link">url</attribute>
                <attribute>button_text</attribute>
                <attribute>second_button_text</attribute>
                <attribute>second_button_url</attribute>
                <attribute>background_image</attribute>
                <attribute>background_video_mp4</attribute>
                <attribute>background_video_webm</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>et_pb_blurb</tag>
            <attributes>
                <attribute>title</attribute>
                <attribute>image</attribute>
                <attribute>image_alt</attribute>
                <attribute>body</attribute>
                <attribute type="link">url</attribute>
                <attribute>button_text</attribute>
                <attribute>second_button_text</attribute>
                <attribute>second_button_url</attribute>
                <attribute>background_image</attribute>
                <attribute>background_video_mp4</attribute>
                <attribute>background_video_webm</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

Ref: https://wpml.org/documentation/support/language-configuration-files/

This topic contains 8 replies, has 2 voices.

Last updated by pbraun 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
September 24, 2018 at 1:57 pm

pbraun

I am trying to:
translate Blurb Links in the Editor

Link to a page where the issue can be seen:
Home

I expected to see:
A field in the Translation Editor where I can translate my Links

Instead, I got:
No fields. hence I'm forced to translate manually. It messes up my work each time I update default language. All links in translated pages update to default language.

September 25, 2018 at 6:11 pm #2764966

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @pbraun, welcome to the WPML support Forum!

Are these "Blurb links" generated by the theme or plugin? Probably they are not registered for translation in the wpml-config.xml file.

Please take a look at this link to see how to register the element: https://wpml.org/documentation/support/language-configuration-files/ -You can add the custom XML code on WPML - Settings - Custom XML Configuration.

After that please go to the edit screen of the page (original language), do a small modification and save. Then the element should be available on the translation editor.

If you need more help to build the XML code just let me know.

All the best,
Diego

September 26, 2018 at 8:01 am #2766309

pbraun

Hello,

I've added this line of code but this does not help.
It that correct ?

<wpml-config>
<shortcodes>
 <shortcode>
         <tag>et_pb_jt_material_blurb</tag>
         <attributes>
             <attribute>title</attribute>
             <attribute>image</attribute>
             <attribute>image_alt</attribute>
             <attribute>body</attribute>
             <attribute>url</attribute>
             <attribute>button_text</attribute>
             <attribute>second_button_text</attribute>
             <attribute>second_button_url</attribute>
             <attribute>background_image</attribute>
             <attribute>background_video_mp4</attribute>
             <attribute>background_video_webm</attribute>
         </attributes>
     </shortcode>
 </shortcodes>
</wpml-config>
September 26, 2018 at 4:54 pm #2768231

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

The XML code seems ok to me. Did you followed this step?
- Go to the edit screen of the page (original language), do a small modification and save. Then the element should be available on the translation editor.

This step is important to refresh the available fields on the translatio editor.

If the issue persist, please send me the link of the page. I will take a look using the credentials.

Kind regards,
Diego

September 27, 2018 at 10:21 am #2770078

pbraun

I'm sorry Diego but it does not help 🙁

September 27, 2018 at 5:44 pm #2771427

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

In this case please send us a link of a page with the issue. I will take a look using the credentials of the first post.

I also checked the settings of your server through debug log and saw that some items need attention. I've seen some similar issues where the cause was the low value of max_input_vars:
Increase WP memory
Please increase the PHP memory limit to 256mb. Currently this memory is set to 40mb only.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

MaxInputVars
Currently your server is configured with MaxInputVars = 1000, which is too low and can cause problems. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

Kind regards,
Diego

September 28, 2018 at 9:26 am #2773124

pbraun

Hey there,

Here's the link
=> hidden link

thanks

September 28, 2018 at 3:49 pm #2774362

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I updated the XML code on WPML > Settings > Custom XML Configuration:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>et_pb_jt_material_blurb</tag>
            <attributes>
                <attribute>title</attribute>
                <attribute>image</attribute>
                <attribute>image_alt</attribute>
                <attribute>body</attribute>
                <attribute>url</attribute>
                <attribute>button_text</attribute>
                <attribute>second_button_text</attribute>
                <attribute>second_button_url</attribute>
                <attribute>background_image</attribute>
                <attribute>background_video_mp4</attribute>
                <attribute>background_video_webm</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>et_pb_blurb</tag>
            <attributes>
                <attribute>title</attribute>
                <attribute>image</attribute>
                <attribute>image_alt</attribute>
                <attribute>body</attribute>
                <attribute>url</attribute>
                <attribute>button_text</attribute>
                <attribute>second_button_text</attribute>
                <attribute>second_button_url</attribute>
                <attribute>background_image</attribute>
                <attribute>background_video_mp4</attribute>
                <attribute>background_video_webm</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

Now the URL's are available for translation (See screenshot).

If you want, you can also add the type=”link” to the URL's. This way the URL will not be displayed on the Translation Editor, but the links will point automatically to the translation (if exist). THe XML code should look like this:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>et_pb_jt_material_blurb</tag>
            <attributes>
                <attribute>title</attribute>
                <attribute>image</attribute>
                <attribute>image_alt</attribute>
                <attribute>body</attribute>
                <attribute type="link">url</attribute>
                <attribute>button_text</attribute>
                <attribute>second_button_text</attribute>
                <attribute>second_button_url</attribute>
                <attribute>background_image</attribute>
                <attribute>background_video_mp4</attribute>
                <attribute>background_video_webm</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>et_pb_blurb</tag>
            <attributes>
                <attribute>title</attribute>
                <attribute>image</attribute>
                <attribute>image_alt</attribute>
                <attribute>body</attribute>
                <attribute type="link">url</attribute>
                <attribute>button_text</attribute>
                <attribute>second_button_text</attribute>
                <attribute>second_button_url</attribute>
                <attribute>background_image</attribute>
                <attribute>background_video_mp4</attribute>
                <attribute>background_video_webm</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

If you need more help just let me know.

Regards,
Diego

October 2, 2018 at 2:59 pm #2781968

pbraun

My issue is resolved now. Thank you!