This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Post content was missing in the WPML tranlation editor

Solution: - Backup your site - Now go to WPML->string translation - From the "Select strings within the domain: " section search for Guttenberg-{page_id} The page id should be default language page id. for example on the provided link it's 10175, so you should select "guttenberg-10175" - Save the translations for these strings somewhere and delete the strings - Go to page editor in the default language and update it. - Update the translation.

This topic contains 15 replies, has 2 voices.

Last updated by sorenP 5 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 3, 2019 at 11:05 am

sorenP

I am trying to:
Update an existing page and it's translation using the WPML Translation Editor (The one that gives you a form with the original text side by side with the translated content).

Link to a page where the issue can be seen:
Edit this page: hidden link

From the editor, go and edit Danish Translation.

I expected to see:
- The usual blocks for WPML Translation Editor (Title-Body-URL)

Instead, I got:
- Just Title and URL Block - BODY BLOCK MISSING.

What I tried to to:
- I changed the Theme for a WP original one. Error continued.
- I tried to replicate the error on another Post, but could not get it again. This one is the only misbehaving so far.
- Notice that the translation is not missing - if you go to hidden link the content is there.
- Notice there is a new block on the bottom of the translator editor with the current content but no translation.

¿Any advice?
Thanks for the help.

May 3, 2019 at 11:23 am #3733741

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Could lease follow the below steps and let me know if this helps:

1) Make the translation as complete (100%)
2) Now go to the default language and update the post.
3) Send the post to translation again, this should show all the updated items.

Note: If the steps above don't work, I request you to add something dummy text on the default language and update the translation, does this help?

Look forward to your reply.

Thanks

May 3, 2019 at 1:57 pm #3734905

sorenP

Hi Shekar, I followed both of your suggestions and it didn't solve the issue.
I'm still missing the BODY section of the WPML Editor.

May 6, 2019 at 8:54 am #3746025

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

It looks like the login details provided is no longer working, could you please verify the login details once, so I can take a look at the issue?

Look forward to your reply.

Thanks

May 6, 2019 at 9:36 am #3746559

sorenP

Something happened with the user I created for you.
Please try with this user name: wpmlusr2
Use the same password provided before.
(Please let me know how to pass you private details through this chat.
Let me know if it works!

May 6, 2019 at 10:17 am #3746957

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

While I was trying to test the issue, I noticed that you are using an outdated version of the plugin. Since we add fixes and improvements as an update, it's quite important to update the plugin to the latest version before debugging/checking the issue.

Being so, may I kindly ask you to update the plugin to the latest version, it would also be nice if you can check the problem with the latest version and share with us the results.

BACKUP NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Look forward to your reply.

Thanks

May 7, 2019 at 7:54 am #3755009

sorenP

Hi. I updated all plugins to its latest version:
WPML Media Version 2.5.2
WPML Multilingual CMS Version 4.2.6
WPML Sticky Links Version 1.5.0
WPML String Translation Version 2.10.4
WPML Translation Management Version 2.8.5

Problem is still showing in this article:

May 7, 2019 at 8:45 am #3755441

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see the content under the page builder page 10175 section, it's titled "core/classic-block" (screenshot attached) could you please translate the content from here and let me know how it goes?

Look forward to your reply.

Thanks

May 7, 2019 at 11:38 am #3757307

sorenP

It seems that I'm getting to tell you what I feel is wrong.
You see? The content on the LEFT of the core/classic-block is the one that was BEFORE we updated WP to the new version and started with the Gutenberg Editor.
I'm uploading two images. I added a Dot in the first line of the text over the English version, When I click on the translator form, you can't see the block - the English text does not update. Somehow it's taking it from and old content. I cleaned WPML Cache this morning with no avail.

May 7, 2019 at 11:44 am #3757455

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I understand what you are mentioning here. To further debug this issue, I would need to clone your site on my localhost and perform further debugging, I can see you have installed a plugin called wp-clone, which can create backups, Is it ok if I create a backup using this plugin and use it for this purpose?

Look forward to your reply.

Thanks

May 7, 2019 at 2:03 pm #3759087

sorenP

Yes you may.

May 8, 2019 at 3:43 am #3763757

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I tried to create a backup using wp-clone but couldn't succeed in it. Being so, could you please provide me a backup of your site so I can replicate your site on my localhost and perform further debugging.

To send a backup file you can use backups plugins, or use hosting services back up and send it using google drive, Dropbox, etc to us. If you can, I request you to remove the uploads folder from the backup as it will be easy to download due to the size.

I have enabled the private reply so you can send those links in the private reply. If you use some backup plugins installed and you created the packages, you can just provide login details and mention us, we can download it from the site itself.
hidden link

Look forward to your reply.

Thanks

May 8, 2019 at 10:32 am
May 8, 2019 at 11:10 am #3765819

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have asked for the file permission, could you please provide it?

Look forward to your reply.

Thanks

May 9, 2019 at 10:08 am #3774971

sorenP

Ready! Permission Sent