This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: WooCommerce Booking calendar does not synchronize between languages

Solution: update the products and save

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by mikeX 1 year, 4 months ago.

Assigned support staff: Laura.

Author Posts
May 22, 2018 at 4:23 pm

mikeX

If you take a look here for French
hidden link

and here for English
hidden link

You can see the calendar is displaying differently.

I tried syncing with "Sync variables products" under the troubleshoot link which fixed availability for a regular product, but didn't seem to do anything for bookable products.

Any ideas?

Cheers!

May 23, 2018 at 10:57 am #2214466

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I suppose bookings are managed by WooCommerce Bookings, and that would explain why "Sync variables products" didn't work.

Did you follow this documentation?
https://wpml.org/documentation/woocommerce-extensions-compatibility/translating-woocommerce-bookings-woocommerce-multilingual/
You can also check this suggested configuration here: https://wpml.org/de/forums/topic/calendar-in-woocommerce-booking-doesnt-appear-correct/

Let me know if this helps you or if you need further assistance.

May 23, 2018 at 6:12 pm #2217674

mikeX

Thanks, I haven't run into any issues with translating the products using WooCommerce Multilingual.

I also checked the other link and all the following are set as suggested:
_wc_booking_availability _wc_booking_calendar_display_mode _wc_booking_check_availability_against _wc_booking_enable_range_picker

This field should be set to "translate"
_wc_booking_resouce_label

Is there something else I can try?

Thanks

May 24, 2018 at 10:03 am #2221243

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I'd like to have a copy of the site to run some test and eventually escalate the ticket.
We usually suggest to use the free plugin Duplicator, and here is our documentation: https://wpml.org/faq/provide-supporters-copy-site/

I'll enable a private reply so you can safely share the link with me.

May 24, 2018 at 10:40 am #2221828

mikeX

I tried to install and create a duplicator package for you, but I can't get it to work. I use updraftplus for backups, are you able to work with this? Or perhaps you know some tricks to get a duplicator package going?

Thanks

May 25, 2018 at 8:46 am #2227784

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

Updraftplus is fine. I will need plugins, theme and database.

May 25, 2018 at 3:41 pm
May 28, 2018 at 2:21 pm #2239447

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I did some test, and it seems that when the product page is updated, the issue just disappears. Maybe this is because Italian and French translations were added later.

You can do this in a single product page:
- go to WooCommerce -> Products -> All products
- choose the one you want to change and click "edit" behind it
- check the "Minor edit - don't update translations" box
- click "Update"

or you can bulk edit the products
- go to WooCommerce -> Products -> All products
- filter if you need it
- check the checkbox in the upper left corner (near "Name") so you'll check all the products on the page
- from the dropdown just above, select "Edit" then click "apply"
- click on the "update" button without changing anything.

If you want to try the bulk edit, do a backup of your database first.

Let me know if this helps you or if you need further assistance.

May 29, 2018 at 3:15 pm #2246763

mikeX

That worked like a charm... so simple. Thanks for checking further! 🙂