Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Laura 2 years, 6 months ago.

Assigned support staff: Laura.

Author Posts
March 15, 2019 at 10:55 am #3353147

antonioM-65

Por recomendación del desarrollador

"When using WPML I can book a room in a different language even though it should be fully booked"

Go to "WPML > Multilingual Content Setup" in the "Custom posts" section set "Bookings" to "Do nothing"

pero como ves es raro que las indicaciones de WPML vengan en ingles y español al mismo tiempo
adjunto captura y no se como poner booking

gracias

Captura de pantalla 2019-03-13 a las 23.06.57.png
Captura de pantalla 2019-03-13 a las 23.06.51.png
Captura de pantalla 2019-03-13 a las 23.05.06.png
March 16, 2019 at 7:31 am #3359145

Laura
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

Since you opened your ticket in the English forum, I'm going to reply in English. If this is a problem, please let me know and I'll see if I can reassign the ticket to someone who speaks Spanish.

I'm not sure if I understand the issue. "Do nothing" is not an option for custom post types. You should try to set Bookings to "Do not translate", which would be "No traducible".
Does this reply your question?

March 25, 2019 at 3:40 am #3449567

antonioM-65

I want to have Booking Page URL

- spanish, hidden link

- english, hidden link

both have text that i already translate in po files.

Which i would set on Theme Options>Booking Page URL, it seems that i have the possibility to work in different languages however it doesn't work

3. Why moths do not translate?

March 25, 2019 at 5:01 pm #3456513

Laura
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I think English is hidden as I can't see your page.

.po files should be only for strings, not for pages content. How did you upload them? Currently, we have some issues with uploading .po files when the default language is not English, so it could be that.

March 25, 2019 at 9:55 pm #3458377

antonioM-65

Hi Laura,
I opened english.

I upload .po files to the server via ftp.

Why moths do not translate?

March 27, 2019 at 1:58 pm #3471741

Laura
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi,

instead of uploading the files via FTP, could you try to import them with the function in the String Translation page?

If this doesn't work, could I take a copy of your site?

March 29, 2019 at 9:51 am #3489881

antonioM-65

The cause of the problem was that I had spaces / line breaks in the field.

Now it is solved

thanks

March 29, 2019 at 3:06 pm #3492479

Laura
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Thanks.