This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 17 replies, has 2 voices.

Last updated by Lauren 1 month, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
April 7, 2020 at 7:51 pm #5860715

marnixr-3

Converting to ticket for further testing.

April 8, 2020 at 12:52 pm #5865851

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please see my previous private reply and let me know once the migration is completed. Thanks!

April 10, 2020 at 9:18 am #5882535

marnixr-3

hi Lauren,

I'm transferring the site at the moment. it should be there in a bit.

I have to admit I removed the booster plugin field for now and merged the fields with the original field that is already in WOo and was being translated.
I didn't have the patience to wait for sorting out the issue.. i'm sorry!

however.. 80% of the products are missing most images (4 in product gallery and all variation images) of the translated products.

It's also quite messy with links not working properly in the translations (some just dissapear)
I think i used all the right buttons to update everything. so i'm not quite sure where to go and fix these issues.

in additional I can also not get HTML-Forms to display the contact form in the translations eventhought the shortcodes are there

April 10, 2020 at 10:08 am #5883049

marnixr-3

I now also notice that my main page isn't the same in the translations, the product order is different and it's missing the protection section :/

hidden link
original

hidden link
hidden link
hidden link
hidden link

April 10, 2020 at 10:34 am #5883173

marnixr-3

ok, I'm seem to am able to get the images working again.
Somehow I pushed the media translation start button already 10 times, but there are still 8000 images left :/

I haven't figured out yet how to get all the categories back though in the different language homes

April 10, 2020 at 11:22 am #5883485

marnixr-3

and i see now it's also f-ing up my products when translated:
hidden link

hidden link

Images and shipping time are swapped 🙁
This has been a nightmare to get correct in the original language and now the plugin completely messes it up again.

I thought this was the go-to plugin for woo commerce? why doesn't it work properly?

April 10, 2020 at 2:20 pm #5884461

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

If I am understanding correctly, the original issue is not longer a problem. Is that correct? it seems like now the issue is that the variations are displayed in a different order for the translation. Please let me know if this is the problem that you are now referring to. If so, how are these variations added? Are you using a any type of page builder? Has the migration completed so that I can test this new issue there?

April 10, 2020 at 2:21 pm #5884471

marnixr-3

ok.. sorry for the spam earlier.. but i got really annoyed with all that got broken.
I've made a list with items that are still broken and I can't fix.
and a few questions:

Variations are messed up (UK is perfect, translation is messed up)<\strong>

hidden link
hidden link
hidden link

hidden link
hidden link
hidden link (worked before translation was visible**)

hidden link
hidden link
hidden link
hidden link
hidden link
hidden link

Variations AND images are messed up (UK is perfect, translation is messed up)<\strong>

hidden link
hidden link

**Often translated content doesn't show. Have to open translation and click done & complete for it to show.
Here it also happened that only have the page was translated.

Is there an option to replace 1 word in a selection of pages ?

Is there an option to reset attribute translations?

Is there an erase/full-reset product translations?

Why isn't there an auto update all language button on the product page ?!
Now you have to open 4 pages, push 4x done and 4x complete and 4x wait

April 10, 2020 at 2:23 pm #5884477

marnixr-3

Actually, the original issue is still there. I just decided to work around it and reformat my products to save time.

So yes, I don't need to solve the booster issue any more.

sorry for the spam earlier.. but i got really annoyed with all that got broken.
I've made a list with items that are still broken and I can't fix.
and a few questions:

Variations are messed up (UK is perfect, translation is messed up)<\strong>

hidden link
hidden link
hidden link

hidden link
hidden link
hidden link (worked before translation was visible**)

hidden link
hidden link
hidden link
hidden link
hidden link
hidden link

Variations AND images are messed up (UK is perfect, translation is messed up)<\strong>

hidden link
hidden link

**Often translated content doesn't show. Have to open translation and click done & complete for it to show.
Here it also happened that only have the page was translated.

Is there an option to replace 1 word in a selection of pages ?

Is there an option to reset attribute translations?

Is there an erase/full-reset product translations?

Why isn't there an auto update all language button on the product page ?!
Now you have to open 4 pages, push 4x done and 4x complete and 4x wait

April 10, 2020 at 2:25 pm #5884487

marnixr-3

and yes, the migration has finished, but it was the version of earlier today which had allot more issues then my current version has now.

is there a way to update it ?
or do I need to make a new transfer?

April 10, 2020 at 2:29 pm #5884493

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please let me know if the migration is complete, so that I can use the staging site for further testing. To answer your other questions:

Is there an option to replace 1 word in a selection of pages ?
-This depends on how the content is added. If the content is created in the body section of the page, then you will need to update the translation on each page. If the content comes from a plugin or theme string, then you can likely edit the string in WPML ->String Translation and it may update for all pages.

Is there an option to reset attribute translations?
Do you mean to delete the attribute translation? If so, you can go to Products -> Attributes -> Click the attribute you want to delete and click the languages at the top of the attributes list and delete the translated attributes.

Is there an erase/full-reset product translations?
You can delete product translations by going to the list of products and then use the admin language switcher at the top of the dashboard. This will list the products in your secondary language(s) and you can delete them from there. Just be sure to remove permanently from the trash before trying to translate again.

Why isn't there an auto update all language button on the product page ?!
I'm not sure I understand this question. Most button text would be different in each language, so updating all at the same time would not make sense. However, if I am misunderstanding the issue, please feel free to further explain or even suggest a bulk update as a feature request here: https://wpml.org/suggest-a-new-feature-for-wpml/

April 10, 2020 at 2:37 pm #5884515

marnixr-3

it look likes we're writing at the same time 🙂
would live-chat be an option like last time?

April 10, 2020 at 2:52 pm #5884579

marnixr-3

Is there an erase/full-reset product translations?
You can delete product translations by going to the list of products and then use the admin language switcher at the top of the dashboard. This will list the products in your secondary language(s) and you can delete them from there. Just be sure to remove permanently from the trash before trying to translate again.

I'm looking for that admin language switcher but do not find it?

April 10, 2020 at 2:56 pm #5884605

marnixr-3

Is there an option to reset attribute translations?
Do you mean to delete the attribute translation? If so, you can go to Products -> Attributes -> Click the attribute you want to delete and click the languages at the top of the attributes list and delete the translated attributes.

when I click a language other then the one that is the default my page changes to a registration page of another plugin ?

i think there is a conflict here?
I have the same issue when I filter a secondary language for a product

April 10, 2020 at 3:25 pm #5884851

marnixr-3

ok, now i'm pretty sure there is conflict with the AliDropship Woo Plugin plugin.
this one is generating the thumbnails and also is also picking up the redirect when selecting a different language of a product etc