Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 7 voices.

Last updated by srdjan 5 years, 5 months ago.

Assigned support staff: Dominykas.

Author Posts
February 25, 2013 at 10:36 pm #107135

Mona

Just a little bug to report you for the next release of BP Multilingual: when it's enabled and on a directory language (/fr/ for example), users can't crop their avatars.

Is there a way to fix this issue for now?

February 26, 2013 at 7:41 am #107184

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Mona,

This was already reported in and according to the ticket status also fixed. Which version of Buddypress Multilingual are you using please?

February 26, 2013 at 10:57 am #107242

Mona

I sarah,

I'm using BuddyPress Multilingual Version 1.4.2.
WPML Multilingual CMS 2.6.4.1
BuddyPress 1.6.4
WordPress 3.5.1

Yes I'm remembering that I saw this problem in the past, and now I have it in my website. You can see the problem live here:
hidden link
login: aaliyah
pass: test123

Go to /fr/ version for instance and try to upload avatar: the cropping function doesn't run. The problem is appearing even if all others plugins are deactivated except BuddyPress, WPML and BP Multilingual.

February 27, 2013 at 11:29 am #107512

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Thanks Mona,

Let me show this to our Buddypress Multilingual developer and get back to you.

February 28, 2013 at 12:25 pm #107840

Dominykas

Hi Mona,

It was fixed, but I see that we have this problem again.

I'll try to look for another solution and get back to you with the patch.

March 1, 2013 at 7:59 pm #108232

Mona

Thank you Dominykas. I'll wait for a patch or for the next release of BP Multilingual Plugin.

March 21, 2013 at 4:22 pm #113865

Mona

Hi,

Is there something new concerning this issue? Because my non-english users are not allowing to crop their avatars since one month 🙂

Thank you for your help.

July 9, 2013 at 9:23 pm #143133

Ben

Hi, I'm having the same issues right now.

It looks like it's because the includes_url also gets affected when calling the jCrop plugin. The language dir gets inserted into the call:
hidden link

So instead of calling it from "/wp-includes" folder, it is looking for the plugin in "en/wp-includes"

Not sure how to fix this, though.

December 13, 2013 at 12:40 am #307748

jonasL-2

NOT solved. As december 2013 this is still not fixed

July 27, 2014 at 7:53 am #442836

briann-2

Is there a solution to this ?
As of 27/7 2014 it is still not working.

August 20, 2014 at 4:16 am #454469

jonasL-2

NOT resolved, the script files in header have wrong urls in the second wave (cropping process) of the steps.

August 21, 2014 at 11:47 am #455317

srdjan
Supporter

Hi, I would like to inform you that BuddyPress Multilingual 1.5 is out:
https://wordpress.org/plugins/buddypress-multilingual/changelog/
http://wpml.org/documentation/related-projects/buddypress-multilingual/

Please upgrade and check if issues are resolved.
Avatar cropping worked fine with latest version using BP Default or default WP theme.