Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.75 hours from now. Thank you for your understanding.

This topic contains 12 replies, has 3 voices.

Last updated by jennaL-2 3 years, 2 months ago.

Assigned support staff: Dat Hoang.

Author Posts
November 26, 2016 at 10:42 pm #1144874

jennaL-2

Hello again Shekhar!

I'm trying to use the WPML Breadcrumb option properly.
I paste this code <?php do_action('icl_navigation_breadcrumb'); ?> inside "page.php". Btw I don't know if it's the correct place for this...

Anyway, my problem is that the breadcrumb doesn't show fully. However I've set a parent page to almost all my pages. There's only "Home >" showing. I need a helpful hand on this.

-Best
Jenna

November 28, 2016 at 8:17 am #1145192

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for contacting WPML support.

I paste this code <?php do_action('icl_navigation_breadcrumb'); ?> inside "page.php". Btw I don't know if it's the correct place for this...
==> It's your preference where you want to put these files.

Anyway, my problem is that the breadcrumb doesn't show fully. However I've set a parent page to almost all my pages. There's only "Home >" showing. I need a helpful hand on this.
==> Could you please provide a link to the page where the issue is happening?

I look forward to your reply.

Thanks

November 28, 2016 at 10:45 pm #1145978

jennaL-2

Here is a link hidden link
It's the same problem on every page.

November 29, 2016 at 6:00 am #1146047

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

#1
If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

#2
If still the problem exists after performing step #1, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

This info is private and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:
+ Backup (both files and database) your site before giving us your credentials
+ It would be better if you give me the test site rather than the live site.

We'd like to request the permission to disable, enable and install themes and plugins for this site. Please accept this?

I look forward to your reply.

Thanks

November 29, 2016 at 6:11 pm #1146874

jennaL-2

Alright I tried what you suggested. Unfortunately it doesn't work.

I don't see any form for private informations. Maybe you need to send me a special request?

November 30, 2016 at 6:34 am #1147158

Dat Hoang

Shekhar is off today. I'm happy to assist you since then. I hope everything's fine.

I'm opening the private reply again.

I've looked at your issue. It seems that your parent page of this page hidden link (ID = 477 ) is NOT published or public.

Please check this point as well.

December 1, 2016 at 4:36 am #1148363

Dat Hoang

Thanks for your info.

WordPress info is fine.
I can not access your FTP. Can you please check?
So far, you put a PHP code in your Visual Composer editor. I see it's working well.

December 1, 2016 at 3:08 pm #1149025

jennaL-2

My bad! I edited the password, have a look.

I noticed that same phenomenon. And actually, it's only working when written in my theme AND inside any page via visual composer editor. But as soon as I erase the duplicated element (in my theme), the trick no longer works. Hehe 🙂

December 2, 2016 at 4:42 am #1149503

Dat Hoang

It seems really weird.

#1,
I see your current theme is customized a lot. This might be the issue here.
Have you tried to add this code in a default theme, like Twenty Sixteen?

#2,
Can you please confirm this?

We'd like to request the permission to disable, enable and install themes and plugins for this site. Please accept this?

If that's not possible, please use Duplicator ( http://wordpress.org/plugins/duplicator/ ) and create a package for us to download.

Duplicator instruction
hidden link

NOTE:
+ wp-content/uploads and wp-content/cache folders are not necessary, you can exclude them in Create New > Step 1 > Section “Archive” > Files > Enable File Filters.
+ Similarly, you can exclude file extensions by selecting [media] and [archive] as well

December 2, 2016 at 1:06 pm #1150020

jennaL-2

#1 Yes I tried like Shekhar already suggested. Same problem.
#2 You can disable, enable and install themes and plugins for the site. I already made a back-up.

Thanks

December 5, 2016 at 5:10 am #1151042

Dat Hoang

Thanks for your info.

I'm checking the issue. Will get back to you soon.

December 5, 2016 at 7:31 am #1151075

Dat Hoang

I've tested on your site with the theme TwentySixteen and there is no issue. See my attachment.

Taking another look at your original page.php in your theme , it seems the issue is on the_post();:
hidden link

If I move the breadcrumb code above the_post();, it looks fine. See your current site, I updated that code. Or you can see it here:
hidden link

To see the difference before and after my change, you can see at hidden link

December 5, 2016 at 8:03 am #1151097

jennaL-2

Hello Dat,

You've made an amazing work!
I'm gonna take a closer look at your corrections, as I'm not sure to understand everything...

Anyways! Thanks a million for your precious time and support.

- Best
Jenna