This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by Bruno 5 months, 3 weeks ago.

Assigned support staff: Bruno.

Author Posts
April 11, 2019 at 1:17 pm #3588111

mauritsH

I am trying to:
translate my pages but my images are broken.
- I've updated/duplicated the images from "wpml -> settings:
Translate existing media in all languages
Duplicate existing media for translated content
Duplicate the featured images for translated content
Media Translation Documentation

- I've vinkt on "duplicate from" on the page that i've duplicated from

Link to a page where the issue can be seen:
hidden link (not indexable page)

I expected to see:
The images as on: hidden link

Can it possible have something to do with out Offload Media plugin?

Instead, I got: Broken images

April 11, 2019 at 9:40 pm #3593019

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

i did a quick inspect on your front end for the image files and here is the main difference i noticed that might be causing this issue

URL for image that works :
hidden link

URL for image that does not work:
hidden link

April 12, 2019 at 4:32 pm #3600565

mauritsH

I see, do you have any recommendations on this? The URL's should be duplicated like it is on the ENG (original) site right?

Is there a solution?

April 12, 2019 at 5:45 pm #3601137

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

When you created the translation you did it through using "duplicate" or by clicking on the "+" icon and then adding the translation using WPML Translation Editor ?

If you go to Pages->Access your default language page and then use the language switcher at the top to switch to your secondary language you should be able to edit the link to your media within there using the standard WP editor.

additionally the URL of the working images is different than your site's default URL , are you using a multisite ? Has this issue happened with the rest of your media if you check within your media and their URL for the translated media or just these 3 pictures?

April 15, 2019 at 7:38 am #3610545

mauritsH

We used "duplicate"

It works with the "external link" but it isn't the perfect solution. Do you know an easy way to get all the images working properly on the multilingual pages? The plugin should duplicate the image URL inclusive the "different URL" part right?

It is for a few hundred images so its quit a lot...

April 16, 2019 at 5:19 pm #3624245

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

yes if you have an external link and then you duplicate the page the external link should remain intact

i have performed this as a test on a staging enviroment and it worked as expected.

1. Add a new page and inserted an external URL image
2. Duplicated to a few different languages
3. URL remained the same.

If possible please take a screenshot of your page's backend in the default language of how you add the external URL and also bottom of the page your system fields and the rest of the fields.

additionally please create a new page and add an external URL media and then duplicate the page, what are your results ?

April 18, 2019 at 11:15 am #3638701

mauritsH

Hi Bobby, tanks for your reply.

We would like to refrain from using external URL's instead of the WP built in media handler.

We are looking for a way where an image can be used on all different languages without having to duplicate them - We don't care too much about alts not being translated right now.

It seems like we cannot access images that are uploaded under another language.
e.g: On a German page we cannot access images uploaded under English which is weird be cause the plugin is set up like "Translatable - use translation if available or fallback to default language" for media types.

So we're not sure why we're not able to access the pictures that are uploaded under another language. Some assistance here would be perfect. Thanks!

April 18, 2019 at 7:17 pm #3641631

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

The main reason is as mentioned before that there does seem to be an external URL used for your images, i recommend verifying that within your default language page edit area

URL for image that works :
hidden link

URL for image that does not work:
hidden link

You can try the following and let me know your results

go to WPML->Settings->Post Types Translation->Media -> Click on the lock-> set to "Translatable - use translation if available or fallback to default language"

let me know your results

if that does not work i would like to take a closer look if possible

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

April 23, 2019 at 7:56 am #3660181

mauritsH

We’ve found that setting and enabled it, but it doesn’t seem to do anything unfortunately. Let me discuss internally if and how we can best grant you access so we can have a look.

April 24, 2019 at 1:53 am #3668165

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If access is not possible you could provide me with a duplicator package to test locally or even migrate to our staging environment on Cloudways servers.

Additionally please verify that the Media that are being used in your page are media that have been uploaded to your WP uploads folder and not using an external URL because when i examine them i see an external URL and that is where the issue is happening.

April 25, 2019 at 8:11 am #3679985

mauritsH

Hi Bobby,

Unfortunately we can’t provide you access to the website. Is it possible to get on a Google Hangout so we can walk thought the options to get to a solution.

If today is possible it would be great!
We are available any time.

Thanks

April 26, 2019 at 3:46 am #3687501

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Bobby is absent and I'm going to take his ticket until he comes back.

Unfortunately, our only channels of service at the moment is the forum or chat, without audio and video.

When I access your site it looks like the images are being displayed correctly in both languages.

Should it be possible for you to create a package from your site using Duplicator or All in One Migration and create the backup of your site and send me so that I can test in our testing environment?

Thank you.

The topic ‘[Closed] Broken images by duplicating’ is closed to new replies.