This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

You are not logged in. You can view support threads, but not post.
If you are already logged in, please refresh your browser.

This topic contains 44 replies, has 18 voices, and was last updated by  Frances 4 years, 7 months ago. The support staff assigned to this topic is sarah.n.

Author Posts
Author Posts
November 20, 2012 at 3:12 pm #85584

Olivier

Hi,

Since the last update of WPML, my .com homepage is automatically redirect to the .fr homepage after a few seconds.

The browser language redirect option is disabled. I don't know why this is happening.
Would you have any solution to fix this?
Thanks forward for your help.

November 20, 2012 at 4:42 pm #85612

Andreas Neuber
Forum moderator

Supporter languages: English (English ) German (Deutsch )

Dear Olivier,

Strange indeed.
1) Are you using by any chance MAMP?
2) Could you provide us with a link to your website?

November 20, 2012 at 5:16 pm #85620

Olivier

Hi Andreas,

I sent you the info...
Thanks for your help.

November 21, 2012 at 9:54 am #85715

sarah.n
Forum moderator

Supporter languages: English (English )

Hello Olivier,

When I visit your site url I do not get redirected to the .fr homepage. What browser do you normally use? Have you tried to use a different browser?

November 21, 2012 at 3:22 pm #85845

Olivier

Hi Sarah,

I made a new test this morning using Firefox and Explorer.
The .com is still redirected to the .fr.
The issue is the same for the .net, also redirected to the .fr (the .net is normally configured to be redirected to the .com).
I checked the settings for the redirections on my host and domain names providers. Everything seems ok.
I don't understand...

November 21, 2012 at 3:39 pm #85852

sarah.n
Forum moderator

Supporter languages: English (English )

Hello Olivier,

I have asked one of my fellow developers to access your site (this is it correct? hidden link) and he also said he does not experience any redirection.

November 21, 2012 at 3:51 pm #85858

Olivier

Ok... welcome in the 4th dimension...
What can I do?

November 21, 2012 at 6:53 pm #85907

Gytis Repecka

Olivier, is FR your secondary landuage, and EN primary?

I am having pretty much same issue on my site hidden link - primary language is LT, secondary is EN. When I visit the site at first time, I get redirected to hidden link, next time until I clean cookies it loads hidden link by default.

I have language redirect disabled at all.

WPML staff, let me know if you want to examine some test cases and/or check configuration.

November 21, 2012 at 7:34 pm #85909

Olivier

Hi Gytis,

For the info, english is the main language but my website is available in 8 languages in total...

November 21, 2012 at 7:37 pm #85910

Gytis Repecka

So it seems redirection is enabling itself for whatever reason and redirecting to non-primary language by default...

How do we stop that from happening?

November 22, 2012 at 12:44 pm #86003

sarah.n
Forum moderator

Supporter languages: English (English )

Olivier, Gytis

So sorry for the late reply! Please don't get the wrong message here. I am not ignoring you!

I need to get 2nd level support involved to get a second opinion. I'll get back to you as soon as I know more.

November 22, 2012 at 4:09 pm #86066

javier

I have the same problem, I have spanish as principal language, which browser detector disable, when a english browser pass for the web automatic redirect to english.

Also the pagespeed of google:

Note that PageSpeed Insights followed a redirect from hidden link and analyzed the page at hidden link.

Please, How do I fix this?

November 23, 2012 at 2:59 pm #86222

Ernst

I also experience the same problem as described here.

I have a website that uses two languages setup, Dutch and English, where I am using two domains to access each language. E.g.:

mydutchsite.nl <- Dutch language
myenglishsite.com <- English language

The Dutch language is setup as default and the automatic redirection setting based on the browser language is disabled in the WPML language config.

When I access the English homepage or any other page in a clean (deleted cookies) browser it is redirected to the Dutch equivalent within the browser. E.g.:

"myenglishsite.com" redirects to "mydutchsite.nl"

and

"myenglishsite.com/my-english-post" redirects to "mydutchsite.nl/my-dutch-post"

I think the problem can quite easily be reproduced and am looking forward to a solution in the next version in WMPL. If you do however require my assistance in resolving the issue please let me know.

November 26, 2012 at 1:26 pm #86610

Olivier

Sarah,

I made a new test. The issue is not specifically concerning the homepage, but in fact the landing page to the website, still redirecting to the .fr version. I guess if I was in Germany it would be the .de and so on...

If I then choose to go back to the english version (.com), there's no other redirection if I load other pages...

Any help to fix this is welcome!

November 26, 2012 at 1:32 pm #86612

sarah.n
Forum moderator

Supporter languages: English (English )

Olivier, and everyone else that joined in.

Our developers are debugging this behaviour and a fix will be provided when ready. Please wait patiently as you are already doing (thank you for this!)

You are not logged in. You can view support threads, but not post.
If you are already logged in, please refresh your browser.