This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Raja Mohammed 6 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 7, 2019 at 4:20 pm #3552377

matijaG-2

I am trying to:

I translated some pages on web but after that my home page on Croatian language is not appearing/ranking in google but the home page on english is appearing which is not good for the clients?

Link to a page where the issue can be seen: hidden link

Please help me with that so the page on croatian can be visible as it was a.s.a.p.?

Thnx

April 8, 2019 at 4:30 am #3554205

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

This issue is happening because Google Bot follows the browser language redirect. and hence the Croatia language is not getting indexed, Our supported Vinzeno has given a detailed explanation about the issue Please refer https://wpml.org/forums/topic/googleresult-shows-a-mix-of-german-and-english-but-linking-to-the-german-pages/#post-2634375

Let me know if you need further assistance.

Kind regards
Raja

April 8, 2019 at 9:06 am #3555825

matijaG-2

Hi sir,

I turned off browser language redirect and it seems now ok but I didnt change the sitemap in google search console. Do I need to do that or not cause now it is ok?

Thnx

April 8, 2019 at 12:50 pm #3557831

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI there,

Try re-indexing the site and check whether you have any issues with a sitemap, If required you can upload a new copy of sitemap. In most cases disabling browser redirection will help without changing the sitemap.

Kind regards
Raja

April 8, 2019 at 12:54 pm #3557865

matijaG-2

Hi sir,

you mean re-indexing the site in google search console?

Thnx

April 8, 2019 at 1:15 pm #3557979

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Yes, of course 🙂

April 12, 2019 at 11:10 am #3597887

matijaG-2

Hi,

I still have a problem with language browser redirecting. It should be in Croatian but it is on English language? - screen in attach

I will upload new sitemap in google.

I turn on: Redirect visitors based on browser language only if translations exist

but the english language is again first when somebody search in google for the taxi. - screen in attach

I have also problem with MonsterInsight plugin in wp template. Maybe that is connected with the issue? - screen in attach

Thnx a lot

April 12, 2019 at 11:20 am #3598085

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have suggested to disabled Browser language redirect. Please reindex your site after the Browser language redirect option is disabled. This will help you solve your issue.

Regards
Raja

April 12, 2019 at 11:45 am #3598403

matijaG-2

Hi,

I have a problem with new google search console and adding google file through ftp??? Is this ok? - screen in attach

I also checked the link in google and it is still on English language?

Thnx

April 12, 2019 at 1:02 pm #3599135

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Try to reindex the site again from Google console after disabling browser redirect option. The process will take some time to reflect the changes in the search console. I would suggest you wait for at least 24-48hours to see the changes in the search resutls.

You can hold with sitemap submission at this moment.

I hope reindex will solve your issue.

Kind regards
Raja