This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Bruno Kos 5 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
April 18, 2019 at 11:33 am #3638751

Inci-OzgeG

I am trying to: Enabled browser redirect

Link to a page where the issue can be seen: Please check this short url: hidden link

I expected to see: I have changed my browser's language but my website is not redirecting.

Instead, I got:

Could you please help.

April 18, 2019 at 12:57 pm #3639257

Inci-OzgeG

Still waiting for help..

April 18, 2019 at 1:56 pm #3639731

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this. 🙂

Sorry for the delay but usually we are not able to answer immediately, only when the ticket queue is very calm or empty. However, right before opening a ticket, you should find an option to open a live chat session so maybe for future use, you can try that option first and see if that works fine for you. If any live chat colleague is available, you would get a faster response (if nobody answers you in the first 2 minutes, the chat will be transformed automatically into a ticket).

I just wanted to share that information with you as you might find it helpful for future occasions when you will need help with WPML.

Now, let's get down to business:

I would need you to please take a look at the following tickets and please let me know if any from the solutions mentioned there are working for you.

- https://wpml.org/forums/topic/browser-redirection-not-working-4/
- https://wpml.org/forums/topic/browser-redirect-not-working-4/
- https://wpml.org/forums/topic/not-redirecting-to-language-of-browser/
- https://wpml.org/forums/topic/browser-based-redirection-is-not-working/
- https://wpml.org/forums/topic/browser-language-redirection-not-working-4/
- https://wpml.org/forums/topic/browser-language-redirect-not-working-on-our-website/

If you just remove the "-4" at the end, or change it to "-1", "-2" or "-3", you should be able to find even more tickets related to this issue.

In case nothing helps, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

April 19, 2019 at 8:37 am #3644149

Inci-OzgeG

Hi support team, is there any progress ?

April 19, 2019 at 4:22 pm #3647501

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hello.

I have run a few debugging processes already but I was not able to find the issue.

Also, I am not able to log in via FTP using the credentials that you shared.

Can you please check that and add the working FTP credentials in the private fields I am enabling below?

I will be waiting for your response.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week in case you will get back to me this weekend.

Kind regards,
Mihai

April 22, 2019 at 5:57 am #3653957

Inci-OzgeG

Hi Mihai,

I am sending the ftp credentials

Thanks for your help,

April 22, 2019 at 6:12 am #3654001

Inci-OzgeG

I have wrote the ftp credentials but everyone see the username and pass. Why don't you use private ticketing system? It is really hard to understand. Year is 2019 and you dont have private ticketing system. This is so uncomfortable.

How can i send the credentials "PRIVATELY" ?????

Can you please activate the private fields again

April 22, 2019 at 5:20 pm #3657425

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

The private fields I am enabling should not be visible to anyone so please try to visit this page without being logged in or from an incognito window and you will see they are hidden.

I will enable the private fields again below my reply here.

Please let me know if this time things work well for you.

Kind regards,
Mihai

April 24, 2019 at 1:29 pm #3673419

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I wanted to let you know that I'm still investigating this.

I will need you to please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

In order to do that, edit the wp-config.php file inside your WordPress directory and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Now please reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Paste the content (if any) on a site like pastebin.com and then share the link here with me. Please censor any sensitive information.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

April 24, 2019 at 7:13 pm #3676213

Inci-OzgeG

Hi,

I have added the codes that you gave to wp-config.php

And then reproduced the issue but there is nothing in this file: /wp-content/debug.log (File permission 777)

hidden link

hidden link

April 26, 2019 at 12:01 pm #3690495

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Mihai is currently on a vacation, so I am stepping in. From what I see, it works actually. I did this:

- changed the Firefox language to French
- opened hidden link
- it redirected me automatically to hidden link

There are some things to know about this:
- this works ONCE only per cookie session - so if I tried once more, it would no longer work because that is expected (otherwise, visitors would not be able to browse through other languages - redirection would prevent them)
- try doing this when either clearing the browser cookies or within browser incognito mode, this may be in your case if you visited the site already
- by default, cooking will be stored for 24 hours, unless you decide otherwise

Regards,
Bruno Kos

April 27, 2019 at 12:46 pm #3695425

Inci-OzgeG

Hi Bruno,

Thanks for your valuable answer. I really appreciate it.

When I tested in firefox and opera everything is working.

The only problem in Chrome browser. Still same issue even if i clear coookies or testing at incognito mode. How can we make it working on Chrome browser also?

Thanks,

April 29, 2019 at 9:24 am #3701507

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It actually worked for me in Chromium also (same as Chrome, but on Linux). I am using "Version 74.0.3729.108 (Official Build) snap (64-bit)". You can see the settings I set and what happens when I open the page - after it has been loaded, it redirects me to French properly and opens it.

Regards,
Bruno Kos