This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Bobby 1 year, 5 months ago.

Assigned support staff: Bobby.

Author Posts
May 8, 2018 at 9:53 am

daniel jansen

Hi there,

I can't get Browser language redirect to work. I have 2 languages: it and es. I have my browser in italian (the 2nd language of the site). I have cleared all cookies and data, still not working. The theme I use is salient. Can you help me out?

Thx
daniel

May 8, 2018 at 10:45 pm #2041815

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

What are your results with a minimal enviroment ?

please test this:
-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with wich one there is an interaction issue

Let me know your results

also if possible please do verify that within WPML->Languages->Browser language redirection is enabled.

when you test , test in a new incognito window every time

The topic ‘[Closed] Browser language redirect not working on our website’ is closed to new replies.