This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Marcel 2 months, 2 weeks ago.

Assigned support staff: Marcel.

Author Posts
August 8, 2019 at 9:53 am #4361611

markoU-2

Hi, I also have another issue. I would want the pages to be opened in a local (browser) language. If the browser language is chinese, the pages would open in chinese and so on. I didn't get this work yet

August 8, 2019 at 9:57 am #4361621

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Marko,

Thank you for contacting WPML Support.

I see you have the Browser language Redirect already active under hidden link. Did you have any errors using this function?

Doc: https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/

Best Marcel

August 8, 2019 at 9:59 am #4361627

markoU-2

Yes, i know. But when testing from Vietnam with a Vietnamese browser, it opened the Finnish language page first

August 8, 2019 at 12:28 pm #4362857

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

I changed my second browser to Vietnamese and was able to reproduce the issue on your live site and my Cloudways installation.

The first time it was opening correct to /vi, the second time it's switching to /fi (on your live site (fi/fi).

I am still debugging.

Best Marcel

August 8, 2019 at 1:13 pm #4363177

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Marko,

I read in the ticket feedback for the flag issue that the language redirection is working now. So I mark this ticket as resolved.

Best Marcel