This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 10 voices.

Last updated by Baptiste 6 years, 3 months ago.

Assigned support staff: sarah.n.

Author Posts
November 30, 2012 at 1:02 pm #87669

Dag

Hi,

I've deactivated the browser language redirection - but google for example crawls the translated homepage, NOT the original Hompage (german).

That's a big problem, because my main keyword (GEMAfreie Musik) does not exist on the translated page. I already got a negative ranking.

What can I do to solve this problem?

Thanks in advance!

Regards,
Dag

November 30, 2012 at 1:36 pm #87679

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Dag,

Can you please provide the versions of WPML and any of its add ons you may be using?

P.S You can go under "WPML -> Support" and copy & paste the information for this from the screen.

November 30, 2012 at 1:41 pm #87682

Dag

Hi Sarah,

here's the information (in german, hope it's ok):

WPML Multilingual CMS Installiert Ja 2.6.1
WPML CMS Nav Download Nein k.A.
WPML String Translation Installiert Ja 1.5.1
WPML Sticky Links Download Nein k.A.
WPML Translation Management Download Nein k.A.

As I said, google is automatically redirected to the english version of my website (and crawling that one instead of my german page).

Hope you can help me.

November 30, 2012 at 2:05 pm #87688

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Dag,

Thank you. Your plugins are up-to-date which is good.

Can you please check that the "Display alternative languages in the HEAD section." setting is active under "WPML -> Languages -> SEO Options"?

November 30, 2012 at 2:15 pm #87693

Dag

Yes, it is active. I think I switched it today to deactivated and back again to active. So, it should be active all the time, right?

Thanks.

November 30, 2012 at 2:24 pm #87696

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

It should be active yes. I was just informed my 2nd level support that there was a related bug that was fixed for version 2.6.2

I will email you a link where you can download the development version and apply it to your installation.

November 30, 2012 at 2:57 pm #87704

Dag

Hi Sarah,

thanks for the development version. I think it's working now.

Regards,
Dag

November 30, 2012 at 4:30 pm #87722

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Dag, you are welcome and thank you for the update.

December 1, 2012 at 8:02 am #87758

Laura Liliana

hello, same problem here.

my website is retetecalamama.ro. default language should be ro but I get redirected to /en/

WPML Multilingual CMS Installed Yes 2.6.1
WPML CMS Nav Download No n/a
WPML String Translation Installed Yes 1.5.1
WPML Sticky Links Download No n/a
WPML Translation Management Download No n/a

Thanx

December 1, 2012 at 10:53 am #87774

Gytis Repecka

Can I get dev version also?

December 4, 2012 at 12:03 pm #88244

Uldis

Hello, same problem here.

my website is default language LV, hidden link All settings good but first time I get redirected to /en/

Mystic.
Can I get dev version also?

December 4, 2012 at 1:12 pm #88259

Monica

Same problem for me... Can I get dev version also?

December 4, 2012 at 8:51 pm #88384

Sander

Hello,
I have the same thing. Please send the dev,
Thanks

May 5, 2013 at 12:08 pm #124966

Amir
Supporter

I've retagged this thread for better accessibility.

September 4, 2013 at 1:24 pm #160762

Volodymyr

Have the same issue - I've set "Disable browser language redirect", but it still redirects according to browser language settings.
Please help!

WPML CMS Nav
Version 1.2.7

WPML Multilingual CMS
Version 2.6.4.1

WPML Sticky Links
Version 1.2.1

WPML String Translation
Version 1.5.4