This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Bobby 1 year, 5 months ago.

Assigned support staff: Bobby.

Author Posts
April 23, 2018 at 8:13 pm #1776418

richardC-24

I am trying to:
Use browser translation settings, but the website is not auto translating.

Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see:
Browser language is set to German, the website should load the german translation.

Instead, I got:
The default language, which is english

April 25, 2018 at 12:34 am #1800128

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Within WPML->Languages-> Browser language redirection please verify that its activated.

If it is ,then please go to WPML->Languages->Edit languages and let me know your default locale for German.

Also test with a minimal environment and let me know your results as a 3rd party plugin might be causing the redirection to fail

please test this:
-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with wich one there is an interaction issue

April 25, 2018 at 1:52 pm #1811416

richardC-24

Hello Bobby,

The setting for the browser language redirect is on and has been set to "Always redirect visitors based on browser language (redirect to home page if translations are missing)"

For the Default Locale, German is set to de_DE
Japan is also having the same translation issue, This Default Local is set to: ja

I have attached an image of what is set for these languages.

I have also deactivate all none WPML plugins and did a test with my browser language set to Japanese and it is still not translating properly by redirecting the URL to /ja

Would the Language URL format have anything to do with this as well? This setting is set to "Different languages in directories ((hidden link - English, hidden link - French))" I have attached a screenshot of the entire page for you as well.

- Victoria

April 25, 2018 at 6:12 pm #1816989

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Similar issues have happened in the past with certain themes. [j.query related usually]

Were you able to test with a standard theme ? '

from inspecting the network console i can see that something is blocking the browser language redirect from happening at all as its not registering.

April 27, 2018 at 1:48 pm #1861729

richardC-24

A test was done on the Twentyseventeen standard wordpress theme and the pages still will not automatically translate based off of the browser language.

April 28, 2018 at 9:00 pm #1878204

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

April 30, 2018 at 2:48 pm #1899408

richardC-24

Thank you for your assistance. Before I do supply the WordPress Admin, and the FTP information I have two questions for you.

1) Do you have an estimated amount of time on how long this may take?
2) Will the website be down for any amount of time?

-Victoria

April 30, 2018 at 5:41 pm #1902647

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Victoria,

Until i have tested the site on my local environment i cant say for sure how long this might take, it might be a quick solution if this is due to a compatibility issue (ex. deactivating the plugin causing this)

or if further debugging is needed it could take a bit longer but regardless we will make sure the process goes as smooth and fast as possible.

for this issue i do not think there will be any downtime.

May 2, 2018 at 2:20 am #1919647

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

The browser language redirection issue is caused by the following plugin

Really Simple SSL

Deactivating the Really Simple SSL plugin resolves the issue

May 3, 2018 at 5:12 pm #1963840

richardC-24

Hello.
The Plugin has been dissabled however when I did a test for the automatic redirect, the site is still not changing.
Please see the attached example of the Japanese language test

May 3, 2018 at 5:53 pm #1964702

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

This is strange.

I deactivated any other random plugin and it worked again just the way it had worked when i deactivated Really Simple SSL.

Are there any rules within your .htaccess file ?

do you currently have caching enabled through your server ?

What are your results if you completely remove W3 cache ? (sometimes it requires to be fully removed )

May 3, 2018 at 8:26 pm #1966043

richardC-24

Hello,

In the .htacess file, nothing strange is in there. I can provide a screenshot if you would like.
this site is using W3 Total Cache however this plugin has benn dissabled as well.

I proceeded to remove the caching plugin and I am still having the same results.

May 4, 2018 at 8:48 pm #1982082

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I had my colleague test this and he was able to be redirected correctly every time he accessed your site.

this was done with a new incognito window everytime and using a German browser.

if possible please test this with incognito windows and with a seperate browser set to German or Japanese

The topic ‘[Closed] Browser Translation’ is closed to new replies.