If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
Buddypress profile specific tabs which have slug like the pages as explained in problem will redirect to pages rather than the profile tab.
http://domain.com/user/apps/
https://domain.com/instructions/apps/

Solution:
- Set Languages per directories option.
- Add the following code in your config.php:

 define( 'BPML_USE_VERBOSE_PAGE_RULES' , true );

Relevant Documentation:
https://wordpress.org/plugins/buddypress-multilingual/

This topic contains 9 replies, has 2 voices.

Last updated by Andrés 2 years, 9 months ago.

Assigned support staff: Andrés.

Author Posts
January 24, 2017 at 6:28 pm #1189746

John

I am trying to:
activate the wpml but have problems after activation. Pages are redirecting with no reason
URL of (my) website where problem appears:
hidden link
I expected to see:
hidden link
Instead, I got:
page redirects to
hidden link

Steps to duplicate the issue:
Deactivate the plugin WPML.
- Pages works fine.
Activate the plugin WPML.
- Pages redirect to above given url with no reason.

there are some others urls as well
hidden link
redirects to
hidden link

January 25, 2017 at 2:58 pm #1190579

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello John,

Welcome to WPML support forum.

It looks like an odd situation, let's try a couple of things:

1. Can you please go to Settings > Permalinks and save your settings again?

2. Please check if this issue appears when:
- All non WPML Plugins are disabled. It will tell us if there is an interaction issue with other plugin.
- Theme is set to a WordPress default like Twenty Fourteen. Its will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.

Best regards,
Andrés

January 27, 2017 at 8:23 pm #1192730

John

Actually it is supposed to be work with buddypress, bbpress. We have some pages there. Even if i turned off the other plugins its still redirecting to the page rather than profile of buddypress.

1- All plugins are disabled it will work fine.
2- Theme is compatible with wpml and they have listed it compatible on their selling pages.
3- One by one activation stops on the first plugin which is buddypress as i told earlier buddypress profile specifc tabs which have slug like the pages as explained in problem will redirect to pages rather than the profile tab.

January 30, 2017 at 8:48 am #1193365

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Thank you for your latest details. It was not clear for me that this issue was caused by sharing the same slug. I have replicated it on a clean install and I will transfer this situation to our 2nd tier support.

I'll keep you updated of any news.

Regards,
Andrés

January 30, 2017 at 3:23 pm #1193888

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello,

Could you please add the following in your wp-config.php file?

define( 'BPML_USE_VERBOSE_PAGE_RULES' , true );

Does it help?

Regards

January 31, 2017 at 9:02 am #1194534

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Please, don't forget to use the Languages per directory option in WPML > Languages > URL Format.

Does it work for you?

January 31, 2017 at 8:18 pm #1195370

John

Thank you for your assistance. Here are my test result after following the steps.
1-

define( 'BPML_USE_VERBOSE_PAGE_RULES' , true );

i added this into the wp-config.php file but it didn't make any difference.

2- As per your suggestion i tried the language per directory option. But it made the profile page of buddypress blank. I tried to add /en/ at the end of the profile page url but it redirects to original url may be because eng is default language e.g.
hidden link

" Language name added as a parameter " This option show the page but redirection issue is still same profile page keep redirecting to other child page with same slug.

hidden link (Profile Page - Tab like Messages/Activity etc...)
redirects to
hidden link (Instruction Page is of Page Post type and apps is the child page of instructions page).

If we turn off the plugin profile pages works good without redirection.

February 1, 2017 at 8:08 am #1195650

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

You need the Language per directory option activated in order to work. Could you describe what happens when you activate this option? Maybe add some screenshots?

If you want to add the language parameter, it has to be added just after your domain. Let's say English is your default language and french your secondary. It would be something like:
hidden link [english]
hidden link [French]
Also, it is easier if you add a language switcher from WPML > Languages options.

Finally, you can check the following doc to see why this option does not work if it is the case:
https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

February 2, 2017 at 5:40 am #1196915

John

It seems that its resolved. I have to reconfigure the settings have to reset the permalinks and things went good this time.

I did some testing and debugging using the url you mentioned above and made it work this time. Thank you for your assistance.

February 2, 2017 at 6:26 am #1196934

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Awesome!
Have a great day,
Andrés