This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Performance issue happens with these symptoms: Translations sometimes are not saved to the database. CPU-Usage is up to 100%.

Solution:

The latest version of WooCommerce Multilingual (4.6.2.1) solved this issue. Please update WPML and its add-ons to their latest versions.

This topic contains 3 replies, has 2 voices.

Last updated by rolandd-5 5 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
April 13, 2019 at 6:38 am #3603667

rolandd-5

Hi,

There is a bug in WooCommerce Multilangual plugin.
When Stock management enabled, the Woocommerce checkout is very slow (12 seconds). A normal checkout takes 3 to 5 seconds after re-directing to the thank-you page.

I can reproduce this over and over again:
1) Enable stock management on products -> check-out is slow
2) Disable stock management on products -> checkout is fast.

It has nothing to do with the theme, other plugins or whatsoever. Tested that too. Spend already debugging for 8 straight hours now.

The only way to keep stock management enabled and having a fast checkout is reverting back to WooCommerce multilangual plugin V 4.3.7

Also other people complain about this. See:
- https://wpml.org/forums/topic/wpml-and-woocommerce-checkout-is-slow/
- https://wpml.org/forums/topic/woocommerce-checkout-is-extremely-slow/
- https://wpml.org/forums/topic/wpml-causing-extremely-slow-checkout-in-woocommerce/

The last link has the exact same issue!!

This is a major bug and have to have the highest priority.

Regards,

Roland

April 15, 2019 at 7:25 am #3610481

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Roland.

This issue was already reported to us and our second tier supporter escalated it to our developers. You can see a reference for this issue at the next forum ticket.
https://wpml.org/forums/topic/slow-checkout-in-wcml-4-4-x/page/2/
I can also confirm that this is happening on my test site. When I enable the option "Enable stock management at product level" on a particular product and check out with this product it increases the check out time in around 5 seconds.

I'll now set this ticket as escalated t our developers, and when I have news about this issue, I'll update you here.

Best Regards,
Itamar.

April 29, 2019 at 10:07 am #3701981

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

This issue is already fixed with the latest version of WooCommerce Multilingual (currently 4.6.2.1) Could you please update WPML and its add-ons including WooCommerce Multilingual on your site to the latest version and make sure that the issue is resolved?

Thanks,
Itamar.

May 2, 2019 at 6:25 am #3722071

rolandd-5

In my small test, this problem seems to be solved.